Republic Veteran
Join Date: Aug 2012
Posts: 500
Please feel free to move this if in the wrong area.

I noticed that the new Nvidia driver is out. I have had major issues in the past with new drivers and my video cards. I am currently using a GTX 560 and the driver I currently have (Ver. 310.70) is very stable.

Has anyone installed the newer driver? If so, are you having any issues? I sometimes fret having to install new drivers from Nvidia as half the time I have to rollback to an older version after several driver crashes.

I also occasionally get character flickers regardless of the settings I am on (either the recommended settings or ultra). Anyone else having that issue? It's not a deal breaker by any means. Just sort of annoying at times. It's not something that happens all the time. Just every now and then.

Any feedback is welcome.
_______________________________
To answer your question, yes. - @Executive_Emily - I have a Website? Oh, yeah! I do.
Survivor of Romulus
Join Date: Oct 2012
Posts: 1,336
# 2
02-18-2013, 10:08 PM
Quote:
Originally Posted by olivia211 View Post
Please feel free to move this if in the wrong area.

I noticed that the new Nvidia driver is out. I have had major issues in the past with new drivers and my video cards. I am currently using a GTX 560 and the driver I currently have (Ver. 310.70) is very stable.

Has anyone installed the newer driver? If so, are you having any issues? I sometimes fret having to install new drivers from Nvidia as half the time I have to rollback to an older version after several driver crashes.

I also occasionally get character flickers regardless of the settings I am on (either the recommended settings or ultra). Anyone else having that issue? It's not a deal breaker by any means. Just sort of annoying at times. It's not something that happens all the time. Just every now and then.

Any feedback is welcome.
Hm, my nvidia update check thingy does seem to lag or something, cause it says no new updates are available. But yes on their site I too see this new driver, so I'll get it later today/tomorrow. Will post again if I crash or notice any changes. (GTX 570 here btw.)

EDIT: Of course I had to get it immediately. lol Did an "advanced - clean" install and it updated all but the PhysX driver that were the same version. It seems to work fine at a first glance, maybe even slight better anti-aliasing. Hard to tell when you're as tired as I am atm.

Last edited by idrona; 02-18-2013 at 10:33 PM.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 02:38 AM.