Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Lt. Commander
Join Date: Jun 2012
Posts: 115
# 1 Serious Bug issue
02-25-2013, 01:25 PM
Ok since no in game tickets are getting addressed... here goes...

i find that after coming back after a few months to check on the status of the game that I am now suddenly unable to access anything past the first 4 ships on any of my characters. I PAID for those slots and regardless what is done, including file by file verification, I am unable to place Bridge Officers on those ships.

You all make the decision of me leaving the game along for 60+ days an easy one and I am will continue this complaint and Get hold of the Sacramento and for PW International in Los Angles BBB and just file a complaint along with possible legal action after sinking the $700+ dollars into this .... complete farce and absurdity that you all call a game.

Your support structure for placing a help ticket has been broke since I left 60+ days ago. not fixed.
To get hold of anyone to address any issue is like trying to find your way out of a wheat field, blindfolded in the middle of Kansas and your destination is Boston.

Either email me at the email i have on my account with some sort of resolution or further correspondence from me.

Sure you could do the cowardly thing and simply close it and ignore it, get a chuckle or two. Feel confident however when someone gets that BBB complaint they might just stop and ask.. ok... WHY did it take this for us to hear our customer?
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 01:44 AM.