Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lieutenant
Join Date: Nov 2012
Posts: 30
# 11
01-12-2013, 04:22 PM
I would also like to add that the hot restart doesnt function after getting engine power zapped.

still just sit there til the debuff lingers away.

engine is a complete waste of time and dil.
Ensign
Join Date: Nov 2012
Posts: 15
# 12 Think again
01-21-2013, 11:06 AM
Quote:
Originally Posted by synkr0nized View Post
edit: didn't see that you had posted, stirling, while I was writing mine. I think we've more or less covered the same thing, but I'll leave this post as is anyway.


It sounds like you folks aren't familiar with "efficient" on engines overall, or at least the Honor Guard engines. It's not a bug in any coding, it's how engines with efficiencies have functioned for quite a long time.

Often you will have "Efficient at high" or "Efficient at low" power engines. This means that the higher or lower your power settings are will affect the bonuses. In this case, the engine is efficient at low power settings. This means that the higher your weapons, shield, and aux power settings are the lower the bonus; if they are high enough, you get no bonus.

Your power settings for your ship are obviously not present when you are on the ground. They are also not present when traveling in sector space. As a result, looking at an engine like this in either of these situations will only show you the max bonus you can receive for these powers. Only when the settings are active, such as a solar system or mission or combat area, will you see the actual bonus applied relative to your powers. And you'll also be able to see how it changes when you cycle through different power level settings (you do have more than one set up, right?).


While you might have a case that it's not a straightforward visual / interface choice, it's certainly not a bug. The KHG engines are perfectly fine, so don't sit on your thumbs thinking the adapted M.A.C.O. needs to be "fixed".
Not true. Look at the Jem'Hadar combat engine. It is efficient at low settings and gives a +2.5 weapon power levels on top of your current settings then it gives a +7.5 additional weapon power "bonus increase at low weapon power". So the Adapted MACO engines are clearly being misrepresented by Cryptic/PW.
Ensign
Join Date: Feb 2013
Posts: 3
Quote:
Originally Posted by synkr0nized View Post
edit: didn't see that you had posted, stirling, while I was writing mine. I think we've more or less covered the same thing, but I'll leave this post as is anyway.


It sounds like you folks aren't familiar with "efficient" on engines overall, or at least the Honor Guard engines. It's not a bug in any coding, it's how engines with efficiencies have functioned for quite a long time.

Often you will have "Efficient at high" or "Efficient at low" power engines. This means that the higher or lower your power settings are will affect the bonuses. In this case, the engine is efficient at low power settings. This means that the higher your weapons, shield, and aux power settings are the lower the bonus; if they are high enough, you get no bonus.

Your power settings for your ship are obviously not present when you are on the ground. They are also not present when traveling in sector space. As a result, looking at an engine like this in either of these situations will only show you the max bonus you can receive for these powers. Only when the settings are active, such as a solar system or mission or combat area, will you see the actual bonus applied relative to your powers. And you'll also be able to see how it changes when you cycle through different power level settings (you do have more than one set up, right?).


While you might have a case that it's not a straightforward visual / interface choice, it's certainly not a bug. The KHG engines are perfectly fine, so don't sit on your thumbs thinking the adapted M.A.C.O. needs to be "fixed".
This clarifys things for me. Thank you. Im sure im not the only one who read it and said to themselves "oooooohhh so THATS what it means" I thank you for that. I will also add that not only is your explanation quite clear I just tested my Adapted MACO engines by lowering the power levels to 25 (cant seem to get them lower) and low and behold the MACO engines repoted a +2.5 wep power boost (still not what is reported but at least I see the mechanics working). When I selected my full power to weapon scheme the bonus to wep power dropped to 0 again.

So I can say to others that your post is accurate. (intended by the devs or not? is not for me to say but the mechanics work as stated)

The other poster makes a interesting point about the Jem Hadar engines that claim "efficient at low power" but give a +2.5 at all times. I can very easily understand why so many players are confused. Those engines are just about everyones first experiance with powerbosting engines.

Most games do not require a equal amount of testing/reading/trial as they do playing time. STO requires a huge investment of time outside of the game itself to truly understand the mechanics. They constanstly evolve on top of it. I really like Star trek online but this is easily it largest negative.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 03:39 PM.