Lt. Commander
Join Date: Dec 2007
Posts: 120
yesterday i entered my deluxe key and it got accepted.
I got redirected to a subscription site and i filled in my cc data etc..
Then i clicked submit and there was an error.
Now my key is allready in use but my account is not activated.
I cant find any link to a manage payment method or whatever.
When i want to log in to STO it says "you are not allowed to login.

Now how am i supposed to fix this because the forum is overwhelmed with all kinds of issues atm.
And dont give any crap answers like wait five or ten minutes or whatever cause i paid 60 euro's for a game i cant play.

Update: so after a few tries o could login so i guess it was just a way of saying that the servers were full or whatever..
Anyhow my account is still incomplete since i have no nice goodies to redeem whatsoever.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-03-2010, 11:35 AM
having the same issue with my account too.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-03-2010, 11:46 AM
Contact billing by telephone or the ticket system. They will get you sorted fast once they get in contact with you.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4 Same issue
02-03-2010, 02:01 PM
When i submit my debit card info into the subscription form it gives me an error. Now i had the same error when i used to play SWG it has to do with the server taking to long to verify with the bank. I used Paypal and it worked fine
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 04:49 AM.