Lt. Commander
Join Date: Dec 2007
Posts: 120
Like many other people, I'm experiencing the random crashes during ground missions. Many people have said this is related to 64-bit Windows, or Windows 7, but after researching and testing on my own, I believe it's an issue with ATI cards and the dynamic lighting setting in the game. Since I'm running a Core i7 system with an ATI 5850, I cranked all the graphics up all the way, and haven't had any other issues. Only on ground missions, whether there are a bunch of NPC/human players on the screen or not.

As soon as I disabled dynamic lighting, the issue has seemed to go away.

This sucks, because I quite like the dynamic lighting, especially in space battles. Here is my DxDiag dump. Let me know if you guys need me to do anything. I would love to see this fixed!

DOWNLOAD my DxDiag file if you need it.

P.S. I'll try to get a client dump the next time the issue occurs... if I can escape back to Windows without closing the client.

Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7600) (7600.win7_rtm.090713-1255)
Language: English (Regional Setting: English)
System Manufacturer: INTEL_
System Model: KBIBX10J
BIOS: Default System BIOS
Processor: Intel(R) Core(TM) i7 CPU 860 @ 2.80GHz (8 CPUs), ~2.9GHz
Memory: 4096MB RAM
Available OS Memory: 4086MB RAM
Page File: 1134MB used, 7035MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7600.16385 32bit Unicode

Card name: ATI Radeon HD 5800 Series



UPDATE 1 (from ticket):

Cryptic:
Greetings! In your ticket, you mentioned that you left Post processing on while toggling Dynamic Lighting. Have you tried disabling Post processing while keeping Dynamic Lighting on? - Cryptic Studios Technical Support

Me:
Thanks for the suggestion. This is something I tried before, and it didn't make a difference either way, but I decided to run through several tests with the latest builds of the game. Here's what I found:

- with Dynamic Lighting, post-processing, and 5 lights per object all on, I can get the game to freeze on ground missions every time.

- with Dynamic Lighting, post-processing, and only TWO lights per object, the framerate takes some pretty hard hits during combat, but I have never had a freeze.

- with only post-processing and 5 lights per object on (DL is off), I get no crashing issue, but slightly less framerate slowness.

- finally, with Dynamic Lighting and 5 lights per object on (PP is off), I still get no crashing, but more framerate slowness

So the issue appears to be be a combination of Dynamic Lighting and having more than two lights per object, at least in my scenario. I should mention with my hardware, I can run games like Crysis at full 1080p with literally everything turned up, including AA, post-processing, and dynamic lighting, with no issues. I hope this information helps out. I noticed a big difference with/without PP and DL, so I would love to enjoy the game in it's full visual style if possible!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-03-2010, 07:15 PM
UPDATE #1

Just had the issue occur on Hide and Seek > Lost and Found. The game froze then crashed about 5 seconds after I engaged the Klingons after beaming down. Ironically, I played through the entire Diplomacy level (with the shapeshifter) with no issue. Maybe being outside on the ground is different than being inside? I've never had the issue on outside ground levels.

Here's the DUMP Error Ticket ID: 9330021

Hopefully this helps. I'm going to play without dynamic lighting on, and see if any other setting is causing this issue. Hopefully the right people are seeing this. I'll update with my future findings.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-06-2010, 02:59 PM
i have almost the same setup and the same problem with ground missions. I am going to try the dynamic lighting option you wrote about. i am running windows 7 64bit
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
02-06-2010, 03:36 PM
I am experiencing this too and it also seems that it only happens on the inside of facilities. It's new for me though, it was not happening earlier. The only thing I changed was to enable vsync. I'm going to try to disable that and see what happens. I'm running the Catalyst 10.1 drivers on Vista x64 with a 1GB 4870 card, btw. What drivers are you folks running?

After the crash it dumps you to the end of the login queue, which just sucks. There should be some grace period or something.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
02-06-2010, 03:45 PM
hmm got to try to deactivate that dynamic lightning...

i am experiencing crashes in ground missions also, got an ati card as well, but im on windows xp.

i have crashes inside facilities and outside.... every ground mission or inside of a station has about a 50% chance of crashing... so damn annoying
a friend with an nvidea card has no problems at ground missions.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
02-06-2010, 04:03 PM
I have this problem won Windows 7, but with an Nvidia card. And my problem goes with inside or outside ground missions regardless of graphic setting. Everything in space is perfectly fine.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
02-06-2010, 05:40 PM
I have the same issue with ground missions now and then. I have an ATI 4870, but I'm running 32bit. I'll try to turn off dynamic lighting and see if it helps.

I only have this issue in space when Ferengi are involved. Which is really weird. Ferengi space merchants crash the game while loading the item list. Other space merchants don't do this, Ferengi do every time. I also crashed on that mission where you have to chase down the Ferengi ship that stole the stuff from the starbase. Did fine killing the other ships in space, as soon as I went after the Ferengi ship and scanned it the game died.

Ferengi are broken lol.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
02-08-2010, 06:40 AM
Wow I didn't expect to happen with nvidia cards too. So far, after turning off dynamic lighting, I've had zero issues since I originally made this post. Sadly, I haven't received a response to my ticket yet. But from what I'm hearing, that's pretty normal with the amount of people who are submitting them.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
02-08-2010, 06:53 AM
Same issue here. Two ATI Cards in Crossfire, Windows 7 RC-1 64Bit. The issue seems to happen mainly indoors but sometimes also happens outdoors, but only on away missions. Space-Combat works fine. The Starbases also don't seem to be a problem. I'll try to deactivate dynamic lighting tonight but I hope it'll be fixed soon so space-battles look awesome again. Also, I have the Ferengi-Merchant-Bug-Crash.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
02-08-2010, 07:45 AM
I was having the about the same problem. I have been playing in full windows mode since i have two monitors and like to work on the second on flights. Leaving the graphics alone i changed it back to full screen (not windows full screen) and I have not had a crash in ground missions for the past 4 days. I will try to put it back to windows full screen in a day or so for a test because i miss being able to use my second screen
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 04:56 PM.