Lt. Commander
Join Date: Dec 2007
Posts: 120
I'm not sure what the deal is but every time I try to activate two powers in rapid succesion it...doesn't work. Sometimes the second power even has its graphic go off without actuallying activating. This is intensely frustrating and has lead to death more than once.

Anyone else?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-04-2010, 11:29 AM
Yes I think me as well. Learning to triple-click over here.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-04-2010, 11:31 AM
Yea, I think there's a slight delay between skill uses, gotta wait for the first skill to just go off before the second..
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
02-06-2010, 09:14 AM
This happens to me all the time and is VERY frustrating. I often miss a photon shot while turning because either the high yield didn't trigger or the fire command didn't trigger and by the time I notice it the target is out of the arc.

Please look at this Cryptic. If it's a server/client sync issue then we need skill queuing.

Has anyone else bugged this? I'm pretty sure I did but I'll check the next time I'm in-game.

-Forjo
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
02-06-2010, 11:02 AM
Yes,

It is very frustrating that keypresses often don't work correctly and sometimes even will activate the "activated" graphics of an ability without it actually firing off. I constantly have to look at my hotkey bar for misfired abilities and mash hotkeys several times to get things to work correctly.

Please make my keypresses actually work, this is very basic stuff and very important in a game!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
02-06-2010, 12:18 PM
I must say this is extraordinarily irritating in PVP... no sir RSP wasn't actually on, it was only fake on... lol
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
02-06-2010, 12:35 PM
I am having same issue, even as far as fire all weapons, it seems like the cooldowns keep restting for my cannons and some times it takes 5 sec or more of not hitting any button until i can fire my weapons, very aggravating.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
02-13-2010, 10:47 PM
This right here is my biggest problem with the game, in my t4 escort my powers often take 2-3 mouse clicks to work, this is probably becuase i am having to spam the spacebar so much. The worst is with my emergency power to shields... i hit it, the graphic plays, but nothing ACTUALLY happens, and timer does not reset... this is a major false positive in the heat of pvp. If i wasnt a lifetime member, this could very well be a showstopper as it is something I deal with on a very normal basis
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
02-14-2010, 06:26 AM
I'll throw my substantial weight behind this one... it's incredibly annoying that the controls are so unresponsive. Sometimes I have to press the attack pattern alpha button 2 or 3 times for it to activate. Very annoying.
Lt. Commander
Join Date: Dec 2007
Posts: 120
Thats my 4 cents (because I want to keep the extra 1 cent) for profit while every one else dousnt get the full 5 cents they paid for.


(Currently: Retrieving List of Characters)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 06:40 AM.