Go Back   Star Trek Online > Feedback > Controls, User Interface, and the STO Gateway
Login

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 31
03-05-2010, 04:18 PM
Quote:
Originally Posted by mkenneally View Post
The latest patch has a fix for this issue:

http://forums.startrekonline.com/sho...d.php?t=133293
Hasn't helped me any, still having to multi-click my icons or multi-tap my bound keys to get some powers to fire.
No queueing apparent either !
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 32
03-05-2010, 06:07 PM
I can confirm that.

Still behaves the same way as before the patch. A lot of the time if I try to use one power followed by another, the first will fire and the UI will show the second activating, at which point I quit looking at the UI, assuming it did its job properly.

A later glance shows that the power never activated.

So still bugged.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 33
03-09-2010, 05:27 PM
Agree... Mine tend to freeze for LOONG time on top of that... 5 minutes without key powers = death... extremely bad in pvp...

A few times they were all grayed out throughout whole match...
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 34
03-09-2010, 06:04 PM
Just so you guys know, it seems to be totally fixed on Tribble.

-Forjo
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 35
03-10-2010, 12:13 AM
Not working for me either...I even had my Beam Overload klunk out for a whole session(not sure if this is related to the normal skill queuing). It would atleast show activated on the tray, but was never discharged.

Either way, it bites to see you skill not trigger, especially when you see it cycle on the bar. The only solution Ive found is holding the bound button down for a second or two until confirmation of its activation.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 36
03-11-2010, 11:05 AM
Still having the issue after the latest patch.

As stated by others, it even looks like the skill is activated, but it isn't. So frustrating in PvP where it's a Life and Death thing.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 37
03-13-2010, 06:24 AM
Quote:
Originally Posted by mkenneally View Post
The latest patch has a fix for this issue:

http://forums.startrekonline.com/sho...d.php?t=133293
Not so much. I'm still having this problem also. I had this issue in CO, as well. As others have mentioned, it makes Exploits and timed torpedo strikes very difficult when you can't rely on your weapons to fire.

Me: "Fire torpedoes!"
Crewman: "..."
Me: "FIRE TORPEDOES!!"
Crewman: (frantically pressing fire button) "...uh..."
Me: "Hello?! McFly?!"
Crewman: "Yes sir, I'm trying! Sir, their shields are back up!"
Me: /facepalm

So yeah, a fix for this would be keen.


Z
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 38
03-16-2010, 12:40 PM
Wrapping this in plastic to keep it fresh.

And bump.


Z
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 39
03-16-2010, 12:47 PM
Actually, it's much better for me. I think I might have slowed down my button presses, but I definitely notice the skill getting the grey background, pausing, and then activating. It's not as reliable as the build on Tribble, but I think it's better.

For those of you still having this issue, please patch up to Tribble and see if you still have it. Cryptic will need to know if they've fixed it. For me, I think they have.

-Forjo
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 40
03-22-2012, 06:07 AM
I am resurrecting this zombie because this problem has once again occurred. Powers are not activating and we are going back to having to double-check our clicks.

As for the mods who like to close these and say start a new one, I have. It's here.

I'm trying to raise awareness because this is a very real issue causing gameplay problems -- especially in STFs.

-Forjo
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 09:05 AM.