Ensign
Join Date: Jan 2013
Posts: 19
# 1 Invisable weapons Season 9
04-26-2014, 06:43 AM
In Any map where their are a good number of weapons firing my weapons "Now" go invisable as of Season 9. I can't see my Damage, Can't see by bolts (except for when I use rapid fire, or am VERY close to the enemy)

I can reproduce this bug EVERY single time in Crystal Catastrophy. Now I know lots of people exhibit lag there, but I don't. or rather I didnt at least.

I'm on a 75/mb sec line, Got a 3ghz dual core, and a gddr5 1,024mb graphics card (shader 5.0), 4gbs of ram, running windows 7 ultimate x64. Running the game under direct x11 maxed graphics like before.

I'm flying a scimitar and have 2 Undine antiproton Turrets in the aft+ Borg kinetic beam, and in front 2 Voth dual heavy cannons + 3 Fluidic dual heavy antiproton cannons in the front.
Wearing Romulan engines, and KHG deflector and Shields.

This is an annoying bug simply because I cannot really Tell if im firing at all except by the lill weapons consol and the recycling cool downs there.
Captain
Join Date: Jan 2013
Posts: 1,894
# 2
04-26-2014, 06:59 AM
Quote:
Originally Posted by nativejoe View Post
In Any map where their are a good number of weapons firing my weapons "Now" go invisable as of Season 9. I can't see my Damage, Can't see by bolts (except for when I use rapid fire, or am VERY close to the enemy)

I can reproduce this bug EVERY single time in Crystal Catastrophy. Now I know lots of people exhibit lag there, but I don't. or rather I didnt at least.

I'm on a 75/mb sec line, Got a 3ghz dual core, and a gddr5 1,024mb graphics card (shader 5.0), 4gbs of ram, running windows 7 ultimate x64. Running the game under direct x11 maxed graphics like before.

I'm flying a scimitar and have 2 Undine antiproton Turrets in the aft+ Borg kinetic beam, and in front 2 Voth dual heavy cannons + 3 Fluidic dual heavy antiproton cannons in the front.
Wearing Romulan engines, and KHG deflector and Shields.

This is an annoying bug simply because I cannot really Tell if im firing at all except by the lill weapons consol and the recycling cool downs there.
With the Scimitar I rarely see my weapons anyway. The beast it to big, the bolts are to small.

But I can confirm that this happens often in crowded areas with other ships, including small ones like the Kumari of hegh'ta. Mainly those using cannons, didn't notice it happening with beams.

But its not new, that happened before Season 9. May be its connected to the change on the graphic settings that some notice it now and not before.
Support more story content in STO
Captain
Join Date: Jun 2012
Posts: 515
# 3
04-26-2014, 07:25 AM
Not just weapons but things like grav well disappears also. I wish they could fix it so they dont vanish when your in a high dps team doing a elite stf. Not like its that gfx demanding really.
Ensign
Join Date: Jan 2013
Posts: 19
# 4
04-26-2014, 01:19 PM
Quote:
Originally Posted by revandarklighter View Post
With the Scimitar I rarely see my weapons anyway. The beast it to big, the bolts are to small.

But I can confirm that this happens often in crowded areas with other ships, including small ones like the Kumari of hegh'ta. Mainly those using cannons, didn't notice it happening with beams.

But its not new, that happened before Season 9. May be its connected to the change on the graphic settings that some notice it now and not before.

Oh They are Clearly visable to me. Expecially at 9k back from the Target. And the Undine weps are HIGHLY VISABLE...so you definetly notice when the Tracers shots run out.

Hrmmm... well as of now it hasn't really hurt my dps because occasionally I center myself behind my ship to "make sure" my invisable rounds are on the target.

Atleast in crystal the target is mostly stationary... I'd be completely Screwed if it was in the new undine stfs where they run around and strafe behind you.

I just wish their was a work around for this bug.

As for the gravity wells disappearing, yeah I';ve noticed that as well.

But for me this is completly a season 9... Probably undine weapons specific bug... because if i use all Voth weapons the bug doesn't occure.
Commander
Join Date: Jan 2014
Posts: 320
# 5
04-26-2014, 03:34 PM
Your technical specs dont matter. It has always been in the game, disappearing visual FX, it just getting more and more obvious now new stuff is constantly being added. The engine simply cant handle it. They know about it, they wont do anything about it. They have very little understanding on the game engine in the first place, and trying to fix something like this can have massive effects on the game which probablyh requires TONS of work.

STO's not going to live long anyway, they're just milking out the last few cents for PWE, and shut it down eventually. The engine cant go on for 5 more years without it being simply super outdated. Graphics covering the fact that its a damn old engine cant go on forever.
::: HIT ME UP IN reddit.com/r/openttd Server 5 Admin :::
Lt. Commander
Join Date: Nov 2012
Posts: 111
# 6
04-27-2014, 11:36 AM
Precisely why STO should render MY stuff first!
I don't care what others are doing, but I've notices STO always seems to render their weapons, shields, and process their sounds over my own.

Client side should always take priority over server side graphics and sounds on the local client.

Until this is fixed I can't do any space battles, because depending on my little weapon CD counter to know if I'm actually firing is a drag and most annoying.

Everything is so much darker, had to adjust brightness to 1.25.
Exchange is dog slow.
Wierd blank black box will go over my chat box for no reason.

Maybe I'll check back in after a month or so to see if any of this is fixed.
Ensign
Join Date: Apr 2013
Posts: 28
# 7
04-28-2014, 06:37 PM
Hi

Some problema here I cannot see my fire (and I use beams) in Crystal Catastrophy and my shields dissapear sometimes also even when damaged.

This did not happen before season 9, and my hardware is the same.

Anyway of counter this ?

Thanks
Commander
Join Date: Jun 2012
Posts: 366
# 8
04-28-2014, 09:39 PM
Quote:
Originally Posted by avastan View Post
This did not happen before season 9, and my hardware is the same.
Yes this did happen before Season 9. Crystaline Entity, and the 20-man Starbase Fleet Defense tended to have it show up rather often.

It's a limitation of the Cryptic Engine. Once so many effects are drawn on the screen, it stops displaying the rest.

There is absolutely nothing you can do to fix this.
"Let's make our DOff UI bigger, clumsier to use, impossible to sort, AND have it show less information in a useable method than we did before!" - Cryptic with STO's 9.5 'crafting upgrade'.

What were you thinking, Cryptic? Seriously. I want to know.
Captain
Join Date: Jul 2012
Posts: 697
# 9
04-29-2014, 10:06 AM
Quote:
Originally Posted by somebob View Post
Yes this did happen before Season 9. Crystaline Entity, and the 20-man Starbase Fleet Defense tended to have it show up rather often.

It's a limitation of the Cryptic Engine. Once so many effects are drawn on the screen, it stops displaying the rest.

There is absolutely nothing you can do to fix this.
Then maybe it would be helpful if I didn't have to see everyones fighters......

Sometimes I cant see whats going on because all I can see are fighters firing beams
Ensign
Join Date: Apr 2013
Posts: 28
# 10
04-30-2014, 10:07 AM
Quote:
Originally Posted by somebob View Post
Yes this did happen before Season 9. Crystaline Entity, and the 20-man Starbase Fleet Defense tended to have it show up rather often.

There is absolutely nothing you can do to fix this.
Well if never happened to me before and I am running a pretty average tabletop... on Crystaline Entity.

So yes its the fault of the new graphics post season 9. As can anyone with some sence see by the number of posts about it.

Dont try to dismiss this as an old problem.

As for the second part I really doubt it since as I said it didnt happend to me before, its just a matter of konwing what changed and how to counter it.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 11:35 AM.