Go Back   Star Trek Online > Support > Graphical and Sound Issues
Login

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
My system runs STO decent but I'm trying to get rid of FPS hiccups. I want my NVIDIA drivers to handle Antialiasing instead of in-game settings as suggested in rockntrek's NVIDIA thread.

No matter what I do, STO completely ignores the NVIDIA Antialiasing Setting (yep I have it turned off in STO). In NVIDIA Control Panel I've tried "Enhance the application setting" and "Override any application setting" - no change at all in STO.

I was running the 190.62 drivers. I thought I might need to upgrade as suggested in Xerove's post so I followed the instructions there. I used Driver Sweeper in Safe Mode to wipe 190.62 clean and upgraded to 196.21. Same result - STO still ignores NVIDIA settings.

Do you think this is because I'm still on Win XP 32-bit? Any suggestions?

Techie Info
----------------------------
DxDiag
3D Settings Pt 1
3D Settings Pt 2
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-10-2010, 03:29 PM
I'm having the same problems!!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-10-2010, 08:09 PM
Try using a nhancer, it's a 3rd party control panel and profile editor that works pretty well with any 3D software together with a nvidia card.

http://www.nhancer.com/

Works for some or if not all apps that ignore Nvidia control panel.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
02-10-2010, 10:31 PM
Quote:
Originally Posted by Roguehwz
Try using a nhancer, it's a 3rd party control panel and profile editor that works pretty well with any 3D software together with a nvidia card.

http://www.nhancer.com/

Works for some or if not all apps that ignore Nvidia control panel.
Thanks but no dice with nHancer. I even manually activated a STO profile and saw no change in AA. Tried restarting STO and creating a new STO profile from scratch... Nada

Anyone know if STO confirmed to ignore driver AA settings?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
02-10-2010, 10:52 PM
ok nHancer created problems I NEVER had before. My FPS has dropped below 10. Reducing all graphics to minimum let me actually move... Turning AA on now produces a crash and driver error.

So far I've tried uninstalling nHancer and cold booting... same problems occur. Great
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
02-10-2010, 11:25 PM
Did you follow the installation instruction properly?

Trying booting up into safe mode Win XP and uninstall all drivers(check add/remove programs as well as the device manager). Reboot for system to re-detect your graphic card and re-install nvidia drivers.

I see that your monitor is a 30" with 2560x1600 resolution... I don't think a GT260 with 512 meg ram can handle a pretty high setting at that screen resolution.Try low shadow, 4xAA, off bloom and turn off occlusion while setting to "recommended" and then check advanced.

Oh, you should know WinXP only supports DirectX 9. Hope you did not mess around with DX10 settings...
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
02-11-2010, 12:01 AM
Quote:
Originally Posted by Roguehwz
Did you follow the installation instruction properly?

Trying booting up into safe mode Win XP and uninstall all drivers(check add/remove programs as well as the device manager). Reboot for system to re-detect your graphic card and re-install nvidia drivers.
Yes, I installed properly and nHancer was running fine although STO did not recognize it's AA settings. I got STO working again by reloading nHancer back and manually activating the Default Driver profile. My FPS was still lower than before nHancer so I uninstalled it and did a clean install of NVIDIA drivers using Driver Sweeper.

Quote:
Originally Posted by Roguehwz
I see that your monitor is a 30" with 2560x1600 resolution... I don't think a GT260 with 512 meg ram can handle a pretty high setting at that screen resolution.Try low shadow, 4xAA, off bloom and turn off occlusion while setting to "recommended" and then check advanced.

Oh, you should know WinXP only supports DirectX 9. Hope you did not mess around with DX10 settings...
That's my desktop resolution not game resolution. And it's a GTX260 with 896 mb ram. I get above 30 FPS at 1920x1200 with some of the advanced graphics options turned down or off.

Yes I'm aware XP only supports DX 9.0c. I think I caused the problems when I saw the nHancer AA settings had no effect. I tried turning in-game AA on to see if the "Enhance Application Setting" worked. I saw that it still had no effect and adjusted the shadows setting. That's when I had bugged shadows across my screen and FPS decreased to 10. Tried adjusting in-game settings again and FPS went down to 1 with a crash to desktop, etc.

In any case, thanks. I think I got my performance back to pre-nHancer. Back to the drawing board...
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
02-11-2010, 09:38 AM
The AA setting has not only been tarnished for Nvidia cards but also ATI - now (atleast with mine which i quote works perfectly fine with AA on other games) cannot enable AA with out lowering quality of the game which last time i checked that wasnt the purpose of AA...
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
02-18-2010, 08:21 AM
GTX 260 ( 196.21 ) - Vista x64
nHancer set to 4x AA
Game set to 8x AA

and THIS is what i get:

http://s4b.directupload.net/images/100218/rjcgydd4.jpg
http://s11.directupload.net/images/100218/zzui3uwr.jpg

it doesn't seem to do AA but if i lower the AA setting in the game it is even getting worse...
it does SOMETHING... just not what you would expect from Anti Aliasing.

i dont get any performance hit from it either but 8xAA should be pretty much unplayable
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
02-18-2010, 10:33 AM
HI! You seem to have a few problems now, so here are some steps and information to fix them.

First: The Nvidia control panel either does not apply AA settings to DirectX many times or OpenGl most of the time. I cannot remember which one, but I am thinking DirectX.

Second: Go get "Driver Sweeper" from Phyxion.net and remove your current Nvidia graphics drivers and install the newest Beta drivers from Nvidia.

Third: I have an issue occasionally where my my game's FPS gets seriously borked. Normally I am chugging around at 60 FPS in space, but then all the sudden it will drop down to like 20 max. Go download the Feb2010 DirectX distributable from Microsoft, reinstall it, and restart. After doing this for me, my GPU utilization dropped by 30-40% (Nvidia 260GTX) and my fps went back up to around 60 FPS most of the time.

Fourth: I have noticed that the ingame AA does work, but it has an issue with some parts ships when zoomed out a fair bit. I have mine set to 8X AA and it gets rid of most all of the jaggies.


Hope this all helps, It did for me!
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 04:39 PM.