Lt. Commander
Join Date: Dec 2007
Posts: 120
# 11
02-19-2010, 08:29 PM
I am using a new Alienware Vista 64 4GB RAM laptop with a GeForce 9800M... this thing can run Mass Effect 2 and other new games like butter, yet I can't play STO at all. Someone gave me a buddy pass, and so far I am unimpessed to say the least. Now, rollouts of ANY new MMO have issues... its to be expected, but I have wasted a lot of time trying to just play the game.

I get the same decompression error (but a different file name everytime). I have forced the launcher validation, and that did not resolve the issue.

I also get the "Min Specs failed" ? What? My drivers are the lastest from Nvidia (since the "latest" OEM Alienware version driver dates back to 2008)...

Now, if you look in the install directory you will see error logs... my hog_errors.log file shows the following:

100220 02:36:41 7 [1]: Hog file incorrect/unreadable version
100220 02:36:41 8 [1]: Unable to read from hogg file! 2
100220 02:36:41 10 [1]: Error decompressing data. Verifying Files in the launcher may fix this issue.
100220 02:36:41 11 [1]: Read wrong number of bytes
100220 02:36:41 12 [1]: Missing DataList in Hogg file -1
100220 02:36:41 13 [1]: Unable to read from hogg file! 8
100220 02:36:42 15 [1]: Hog file incorrect/unreadable version
100220 02:36:42 16 [1]: Unable to read from hogg file! 2
100220 03:55:14 9 [1]: File read from disk has bad CRC. Verifying Files in the launcher may fix this issue.
100220 03:55:14 11 [1]: File read from disk has bad CRC. Verifying Files in the launcher may fix this issue.
100220 03:55:15 13 [1]: Error decompressing data. Verifying Files in the launcher may fix this issue.
100220 03:55:15 14 [1]: Read wrong number of bytes

I am thinking this is due to the downloaded game client. But things have been patched and validated. So why cant my PC play this?

EDIT:

Now here is an entry from the validation log:

100220 03:53:45 1 [1]: Force verify enabled
100220 03:55:14 10 [1]: File checksum invalid in hogg: bin/geobin/maps/Star_Cluster/Ext/Sc_G_Expl_Alien_Obj/Sc_G_Expl_Alien_Obj.Zone/terrain_Default_atlases_0.hogg
100220 03:55:14 12 [1]: File checksum invalid in hogg: bin/geobin/maps/Star_Cluster/Ext/Sc_G_Expl_Alien_Obj/Sc_G_Expl_Alien_Obj.Zone/map_snap.hogg
100220 03:55:15 15 [1]: File failed to load from hogg: bin/geobin/maps/Star_Cluster/Ext/Alp_Hilln/Sc_G_Alphlln_Monu1_001/Sc_G_Alphlln_Monu1_001.Zone/world_cells.region_bounds
100220 03:55:15 18 [1]: File failed to load from hogg: bin/geobin/maps/Star_Cluster/Ext/Alp_Hilln/Sc_G_Alphlln_Monu1_001.gaevents.bin


It goes on and on.... for literally hundreds of lines...

Anyone see this same thing from the retail CD based install and not the web based client?

Edit2: New development. I have tried several "fixes" on the forums to no avail, but now I get

./piggs/bins.hogg: Bin/ActivityLogEntryTyoes.Bin Error decopressing data.

Deleted the bins.hogg file from the directory and force verified again. Now its downloading 3GB.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 12
02-20-2010, 10:27 AM
ok I think I solved it... If anyone reads this... please see how I solved this on my machine.

http://forums.startrekonline.com/sho...33#post2159633

I dont know how to link to the other STO thread other than above. Or if you dont want to click the link search for

"Possible solution to Error Decompressing Data"....
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 13 error decompressing data
02-25-2010, 11:54 AM
It took me a day but I had the same problem and I fixed it. My OS.. Vista 64. w/ quad core running Nvidia 8600. I downloaded the game client to try the 5 day trial. buggy during character generation. I got this off another website but it finally worked...

Step 1: Uninstall game (This will not delete to you progress in the game because all that information is saved on the Cryptic Studios server.)
Steo 2: Reinstall the game, but do not run the game yet
Step 3: Open "My Computer"
Step 4: Open "C: (Local Disk)"
Step 5: Open "Program Files"
Step 6: Open "Cryptic Studios"
Step 7: Open "Star Trek Online"
Step 8: Open "Live"
Step 9: Delete "Piggs" folder
Step 9a: opinion if you are not the admin right click on the game icon, click on "Run as...." the select Admin mode.
Step 10: Start game which will start a 10MB or GB (It's a big file) patch download which can take a while. This should take care of any corrupt files.

Note.. I got this from http://www.jupitercolony.com/viewtopic.php?f=11&t=3610
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 14
02-26-2010, 09:51 AM
This is a horrible way to fix this issue I have yet to play the game without running into this issue at some piont I re-downloaded hogg files 10-15 times yet still one of them gets corruptted why can't the verify just delete the corruptted assests and then re-patch them? It never does this and it should. There is no reason for us to have to re-download a 3 gig file everytime this error happens. Force verify should fix the problem. No other game I know of has this issue. If an assest is corrupted they fix just the corrupted asset not the whole freaking database. Please for the love of god change the way the verifier works.

Okay I found a utility someone made to decompress hogg files and i found out the texture files that are giving us all headaches inside the hogg file are less than 100 KB big. Why oh Why do we have to delete and then re-download a 3 GB compressed archive each time we get this error. Instead of the verifier being able to decompress the archive delete the corruptted few KB redownload those and then recompress the archive. Or a better idea why have a compressed archive at all? I can understand this for downloading purposes but once downloaded why can't the archive be decompressed and then we could just deleted and repatch the corruptted files ourselves. Either one of these solutions would work.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 06:58 PM.