Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Mission: Ground Zero
02-11-2010, 11:45 PM
I just spent 90 minutes completing this mission and once you depart the system, you get no recognition for completing it. I tried to re-enter the system of Habus but it's making you do the mission all over again. Anyone else have this problem?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
03-01-2010, 01:49 PM
yup, just happened to me. i got teamed up with some random person, and it finished for them, but left me with it undone. im ****ed off. i had to do the previous mission (by any means) 4x due to some small bug, or oversight. now this one too. que pa?

way way too many things are not working right. this is very bad.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3 Same...
03-05-2010, 10:48 PM
Same damn thing happened to me!!!! Of course I did it twice now, and both times the quest would not complete. WTF CRYPTIC! YOU SUCK AND YOU OWE ME 3 HOURS OF MY LIFE BACK!!! It's one thing for a random quest to be bugged, but the 90 minuted episodes NEED TO COMPLETE!! JESUS!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
06-19-2010, 05:23 PM
Just happened to me too and it also happened on Hunting the hunters,

Seems to be Admirals T'naes missions that are not letting me turn in, I have petitioned a gm about it as I refuse to do it over and over as I did with the hunter quest and still have it being offered as a new quest.


It's fustrating!!
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 11:34 AM.