Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
So, the Fleet Bank is useless.

I have 2 tabs.

I set 'withdraw' limit to 1, with 'withdraw' rights to set to 1.

The other tab has no withdraw rights set.

People can take as many energy credits as they want to.

When I set the withdraw limit to '0', which I assumed would mean 'cannot withdraw money', the game blanked out the 0's and people could take ANY amount out.

The only 'restriction' I can enforce is by disabling 'withdraw' entirely to a certain rank, which prohibits them from taking useless MKI items but prevents them from taking the hundreds of thousands of credits we've lost because of the useless bank restriction.

Please fix this.

Oh and lower level permissions that are more permissive than higher level permissions, for example:

Rank 1 can withdraw.
Rank 3 cannot.

Rank 3 can withdraw cash anyway, but not items.

So, what's the point of these 'permissions'?

It's a joke.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-12-2010, 02:53 PM
Known bug.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-12-2010, 10:42 PM
i think a more useful system would be to have a setting allowing only a certain amount of withdrawls in a certain amount of time. IE i'd like to be able to set something to the effect of 3 withdrawls/hour or 5/24-hr period. I was just looted 300k by a player, i'm hoping there will be repercussions for these people who are violating cryptic's policy of "Intent to scam another player ", as PMing someone and asking to join their fleet only to loot it at the earliest opportunity and leave the fleet clearly falls into that category.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
02-19-2010, 04:51 AM
So the new money permissions do not work.

Good job Cryptic.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
02-19-2010, 06:12 AM
Quote:
Originally Posted by Stelek View Post
So the new money permissions do not work.

Good job Cryptic.
They work perfectly as of 2/18/10
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
02-19-2010, 06:37 AM
Sorry, is this the forum for trolling monkeys?

Obviously they do not work as of 2/18, since that's when they said they patched it and I just posted.

Sigh. Now that it's 2/19, a new patch and server is up, I'll see if they actually do work.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
02-19-2010, 06:43 AM
They still don't work.

Can you test anything before it goes live?
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 11:58 PM.