Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
It looks like someone screwed up a Z axis value on the galaxy class ship model and it's derivatives. The hull is set too high in relation to the other ship components. The result is that the hull seems to poke through the saucer section on top and seems to be unattached to the large pylon and warp nacelles on the bottom rear.

This shouldn't be hard to fix, just have to change a few numbers really. It's really distracting to anyone playing a galaxy class, and it's easily one of the most iconic ships amongst the star trek fandom. We'd greatly appreciate it if this issue could be addressed fairly soon. Thank you
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-13-2010, 06:01 AM
man this thread gets spammed with crap, I really hope a Dev sees this
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-13-2010, 12:06 PM
wow really, no one commented on this. Has no one else seen the Galaxy class model?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
02-13-2010, 02:24 PM
i can't believe i have to bump this again, maybe no one has gotten to Captain rank yet
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
02-13-2010, 02:51 PM
I'm sure if it is appearing this way on their systems they will fix it in the future. It's not a true bug so I'm sure it something that will just happen quietly. May or may not even see it in patch notes.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
02-13-2010, 02:59 PM
The Galaxy Class in STO looks terribly clumsy in any way!

Just take a look at the Engineering section here:
http://memory-alpha.org/en/wiki/File...he_Voyages.jpg

sleek and smoth

compared to the Ingame Model:
http://media.curse.com/CommunityServ..._101709_70.jpg

Clumsy, distorted and of the Map...

just my 0,02$
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
02-13-2010, 03:17 PM
Quote:
Originally Posted by Hunkey View Post
The Galaxy Class in STO looks terribly clumsy in any way!

Just take a look at the Engineering section here:
http://memory-alpha.org/en/wiki/File...he_Voyages.jpg

sleek and smoth

compared to the Ingame Model:
http://media.curse.com/CommunityServ..._101709_70.jpg

Clumsy, distorted and of the Map...

just my 0,02$
meh, all the ships look like that in this game, and I'm pretty sure that that in game shot is out of date, the saucer doesn't look THAT bad anymore. I just want them to fix this blasted alignment issue. It would take them 30 seconds-all they have to do is change a few numbers

That said: the ship artwork in general for this game is of amazingly low quality. I've never seen a licensed Star Trek game where the ships just looked so... malformed before. I 'm starting to think that they just hired a bunch of day laborers to create their art assets for them. I've seen fan made mods that do a MUCH MUCH better job of capturing iconic Trek ships like the Galaxy class. My guess is that this is do to the way in which players can mix and match ship components. Perhaps this system forces them to compromise the overall look of familiar ship designs?

In any case, all I want is for this alignment issue to be fixed
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
02-13-2010, 07:58 PM
Quote:
Originally Posted by LDE47 View Post
I'm sure if it is appearing this way on their systems they will fix it in the future. It's not a true bug so I'm sure it something that will just happen quietly. May or may not even see it in patch notes.
it's not just on my system, numerous people have complained of the this issue
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
02-13-2010, 09:03 PM
Yeah, just change a few "numbers". LOL
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
02-13-2010, 09:34 PM
Quote:
Originally Posted by exodusrex View Post
Yeah, just change a few "numbers". LOL
there's not much more to it, the component is only displaced by a few notches along the z axis, they just need to move it
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 07:06 AM.