Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Anyone using ATI HD5750?
02-28-2010, 01:39 AM
looking at putting a decent video card in my HTPC so i can do some gaming on my 42" TV. (currently using onboard)

Looking at either the NVIDIA GTS250 1GB or an ATI HD5750.

was leaning towards the ATI and then saw the review of STO at toms hardware. The 5750 wasn't there, but the 5770 was, and that got horrible scores.

Now, that was using old drivers (9.12) so it might've been fixed, but i don't want to buy one and then get the same (well, worse as that was a 5770) performance.

Anyone out there using a HD5750 or HD5770??? how well does it play STO?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-28-2010, 05:33 AM
gonna have a look see at that review as i got 2 5770s yesterday, to replace my 3870s. maybe xfired they won't be that bad.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-28-2010, 07:42 AM
I use a single 5770 to play at 1680x1050. It works fine on quality setting as long as you disable dynamic lighting.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
02-28-2010, 07:56 AM
got DL, and post processing, enabled for space. never had a prob with it there, just planet surfaces/elsewhere
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
02-28-2010, 08:12 PM
this is the review i was talking about.

Im gonna wanna run it at native res (1920x1080) and max detail. The 5750 gets 21fps at 1900x1200. Not exactly the same res, but comparable.

Krenn, are you running yours in Xfire? have you tried single card? what version drivers?

currently im using my main rig on my TV, with an 8800GTX in it. running everything full (ie, 200%), DL enabled, AA @ 4x and AF @ 16x. running smooth @ 1920x1080.
This card has gotta be like 4+ years old now (i think) and it still rocks :p
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
02-28-2010, 08:47 PM
Running a single ATI HD5770 on a 22" at 1920 x 1080. I have Dynamic Lighting turned off and all other settings at max or almost maxed out. I haven't checked what the fps is, but I don't have any stuttering at all.

I've been very pleased with this card and plan on getting a second one for Xfire soon.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
03-04-2010, 07:40 AM
HD5770 with fullHD resolution.
Good framerate, silent and the best value/money ratio at the moment.

And much less stress for the power supply compared to nvidia cards.

The 5750 should be enough for STO. But you would have to turn off some deatils for other new games.

There is a 5750 with passive cooling available. If you want a pc with less noise - this card would be a good choice.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
03-10-2010, 02:53 PM
I am running XFX Radeon HD 5750 XXX Edition, win7-64 with 8gigs of DDR3 ram on a core i-5 mobo and it works fantastic. I did have some pixelation issues with shadows, but after turning shadow detail to low I haven't has a problem. I am running at max resolution on a 23" lcd (1920 x 1080 I think). Zero lag or frame drops.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
03-10-2010, 03:40 PM
great, thanks for that Jerroz!

Can you tell me which version of the Catalyst Control Centre you are using...10.2?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
03-13-2010, 01:50 PM
Quote:
Originally Posted by pantner View Post
Krenn, are you running yours in Xfire? have you tried single card? what version drivers?
yup, xfired and STI sure looks purty. 10.2cat.

still getting crashes with DL/PP enabled, tho. one was a BSOD and had something relating to ATi in the lower left corner of my screen but i didn't get all of it when restarting. i'm thinking there is something to do with drivers
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 05:40 AM.