Go Back   Star Trek Online > Support > Graphical and Sound Issues
Login

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
I have a couple of FPS related issues it seems.

I noticed that if I open my Fleet window my FPS drops to about 8 FPS. (usually in the 50s in space)
All other windows, such as the main Character screen also do this but not quite as drastic.

Also, on the ground I'm getting about 25 FPS on average on "Default" graphics settings. In space I get high 40s and low 50s consistently.

I have the most current Nvidia driver for my Geforce GTX 260 MaxCore 55 card.
I am on WIndows 7 x64. Core2Duo CPU, 4GIG RAM.

Any ideas why FPS is so bad in this game (especially on ground)??
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
03-07-2010, 11:28 AM
Quote:
Originally Posted by Zakoriz
I have a couple of FPS related issues it seems.

I noticed that if I open my Fleet window my FPS drops to about 8 FPS. (usually in the 50s in space)
All other windows, such as the main Character screen also do this but not quite as drastic.

Also, on the ground I'm getting about 25 FPS on average on "Default" graphics settings. In space I get high 40s and low 50s consistently.

I have the most current Nvidia driver for my Geforce GTX 260 MaxCore 55 card.
I am on WIndows 7 x64. Core2Duo CPU, 4GIG RAM.

Any ideas why FPS is so bad in this game (especially on ground)??

Sadly, no, but it may very well be an issue with the card. I have a Geforce 260 GTX on an i7 920 machine with 9 gigs of RAM and am having similar problems. In addition, I have the random freezing and even game crashes (almost exclusively in ground combat.) It was fine in closed beta, had some issues in open beta, but I updated drivers and it was okay until about two weeks ago.

Now, I am running on Vista 64bit instead of Windows 7, but my system was pretty smoking I thought. Bought it specifically for Champions and STO. Now I'm wondering if I should have upgraded.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
03-07-2010, 02:35 PM
I'm running a Geforce 9800GTX+, bottlenecking on PCI-E 1.1, with an "ancient" Athlon X2 4800+ (939) and 4 gig of DDR400 and my slowdowns have gotten to the point that they're minimal. They used to be pretty bad, but once hte card "burnt in", things are a lot better now. The only time I get FPS hits is when I alt-tab and re-open the game or when I'm in ground combat and do something stupid, like open 100 windows. But even then, they're momentary and within a few seconds I'm back up to 40-50 FPS.

How old is your card? Is it getting proper power and/or cooling?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
03-09-2010, 12:58 PM
Quote:
Originally Posted by Zakoriz
I have a couple of FPS related issues it seems.

I noticed that if I open my Fleet window my FPS drops to about 8 FPS. (usually in the 50s in space)
All other windows, such as the main Character screen also do this but not quite as drastic.

Also, on the ground I'm getting about 25 FPS on average on "Default" graphics settings. In space I get high 40s and low 50s consistently.

I have the most current Nvidia driver for my Geforce GTX 260 MaxCore 55 card.
I am on WIndows 7 x64. Core2Duo CPU, 4GIG RAM.

Any ideas why FPS is so bad in this game (especially on ground)??
Same problem here, but i have 8800GTS XFX 512M -.-"
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
03-14-2010, 12:49 AM
Quote:
Originally Posted by Zakoriz
I have a couple of FPS related issues it seems.

I noticed that if I open my Fleet window my FPS drops to about 8 FPS. (usually in the 50s in space)
All other windows, such as the main Character screen also do this but not quite as drastic.

Also, on the ground I'm getting about 25 FPS on average on "Default" graphics settings. In space I get high 40s and low 50s consistently.

I have the most current Nvidia driver for my Geforce GTX 260 MaxCore 55 card.
I am on WIndows 7 x64. Core2Duo CPU, 4GIG RAM.

Any ideas why FPS is so bad in this game (especially on ground)??
I have the exact same issue.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 11:08 AM.