Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
During any space combat enemies multipile levels lower are almost impossible to damage before I am defeated. This problem started at Commander level 1, since I got my heavy cruiser I can't barely take down a level one warbird before I am defeated. During combat enemies are dealing triple digit damage to me but I can only score double digit damage. I have no trouble in ground combat, any help would be appreciated.
Thanks
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
03-09-2010, 02:45 PM
Please check the Power Levels of your Ship, if your Weapon Subsystem doesnt get enough power, your Energy Weapons might even drop to 0 dmg.
If thats the case, try equipping eps console(s).
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
03-09-2010, 04:22 PM
Maybe try changing ships ...?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
03-09-2010, 06:59 PM
Make sure you're at Attack Power, first. Second, if you're running more than four beams without EPS consoles it'll drain your power to almost nothing pretty fast. Emergency Power to Weapons is also a must.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
03-10-2010, 01:26 PM
Quote:
Originally Posted by JonBuck
Make sure you're at Attack Power, first. Second, if you're running more than four beams without EPS consoles it'll drain your power to almost nothing pretty fast. Emergency Power to Weapons is also a must.
Cruisers are supposed to have the normal power transfer abilities to handle multiple beam weapons. EPS conduits only help with recharge. The thing he really needs to do is raise his skills to support his tactics.

But this may be a bug! There are other reports where moving equipment from one ship to another results in a glitch. And at times it almost seems that some ships are glitched. This Thread is an example. So don't jump to conclusions and assume he's not properly equiped.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6 Thanks for all the input.
03-15-2010, 08:26 PM
I am still having this issue w/ cruiser, using a heavy escort is the only way I can have a space battle.
I guess I will have to re-spec skills.
Again thanks for trying to help.

Garth
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 05:21 PM.