Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 51
10-11-2010, 02:19 AM
Congratulations are in order, this bug has just celebrated it's half year anniversary. *bows* It's still there, in it's full beauty. Come to Mylasa and celebrate with us! ^^
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 52 Still?
10-18-2010, 04:05 PM
I'm fairly new to the game, and found this was the first mission I was unable to complete. I put in a ticket, all the while wondering why no one else seemed to have the problem since my search for issues with this mission brought up none.

I tried restarting the mission and ran into the same issues again and again - my BOffs do not come with me. I fought my way through, by myself, thinking that this was the mission "test" although it seemed insane. Finally, when my science officer reported that I had to use the device once more to override it, I got stuck - I killed all the Hirogen and no more turned up, trapping me.

I was able, through switching waypoints and moving around, to get my BOffs into the force field with me eventually but that did no good (I thought perhaps them not being there was why the device didn't activate).

The mission is severely broken. As I am a newer player I am torn - is this an indication of lack of dedication or resources on the part of Cryptic? Do I even bother going through with subscribing to the game once my free trial month ends? I'm about to reach Admiral, and I've really enjoyed the parts of it that work. But - this is a pay service. If the operator of that service is not responding to the customers' needs, and correcting these sorts of errors quickly, they should expect people to demand refunds or other compensation.

If I paid someone to fix my roof, and after they fixed it it still leaked, I'd be upset. If I paid someone for a television, but for some reason it couldn't tune channels 3 or 7, I'd be getting my money back. It wouldn't matter to me if everyone else who bought the TV had the same problem or if only 1 in 10 people had it - it's completely unacceptable to see this has been around like this for so long and nothing has been corrected.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 02:56 PM.