Lt. Commander
Join Date: Dec 2007
Posts: 120
Hi guys, I have noticed the following problem occuring much more frequently (not sure if it is because something was changed or it is just me)

When I cast a space (and occasionaly ground) power, such as Science, Engineering, Tactical Team or EPS Transfer, often the power is getting cast on a team/faction member rather than myself.

This is due to me targetting an enemy and shooting at it, but that enemy has a teammate targeted, and so when I hit the skill that it meant for me, it actually gets placed on that teammate. As I am an engineer that uses turrets etc, on the ground it is not so much a problem (except when summoning drones and sometimes I flip around to cast it on a teammate leaving me exposed to flanks)

Now I wondered if I was doing something wrong, and maybe there is a control option that I can change?
Currently I know that I can hit F1 (to target myself) or Esc to cancel my target, and THEN hit the skill, in which case it is cast upon me.

However, this is time consuming, AND more importantly means I stop firing on my enemy and then have to reset target (difficult sometimes when there are lots of enemies eg carrier mob and we are trying to focus fire on the main vessel).

So is there sometime I am doing wrong, or is this actually more of a bug in the way the game works? Granted that helers/cleric type characters would probably like that functionality of being able to heal the teamate that is getting beaten up on by the target you have currently selected. I, however, am selfish (and in my escort sumwhat of a glass connon) so want to use these skills on myself! I would much prefer the skills to automatically cast on me, except when I specifically have my teammate selected.

Thanks for the help ppl.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
03-26-2010, 03:17 AM
Go to your options and turn of assist targetting or something like that off. It is an option.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
03-26-2010, 09:47 AM
Quote:
Originally Posted by Simon_Picard
Go to your options and turn of assist targetting or something like that off. It is an option.
I was going to say the same thing. And to add to the info:
I fly primarily a science vessel loaded with support abilities, so I leave that option on.
Instead, I hit F1 which automatically targets yourself, even if you are not in a team.
If you are in a team, F1 through F5 will target everyone on your team in face plate order, top to bottom.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
03-26-2010, 02:16 PM
Good question and 2 good answers, on my Engy that was an issue but it seems I was missing a setting.

Thanks !
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
03-26-2010, 03:34 PM
Quote:
Originally Posted by denare View Post
I was going to say the same thing. And to add to the info:
I fly primarily a science vessel loaded with support abilities, so I leave that option on.
Instead, I hit F1 which automatically targets yourself, even if you are not in a team.
If you are in a team, F1 through F5 will target everyone on your team in face plate order, top to bottom.
this is a good answer, but I would like to add that you may need to either hit f1-5 several times or hold it down, otherwise sometimes it can freak out and retarget something (this is prudent in case you're using autofire or weapons are in the middle of shooting)
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
03-26-2010, 07:56 PM
Yeah, I like using the assist option, but when I deselect the target to use on myself, it would still apply it to someone else. I'll just have to make it a habit to press F1 and then the ability (I have it setup to autotarget the enemy firing at me, so unless it deselects me and selects the enemy, it should work fine).
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
03-27-2010, 03:04 AM
Quote:
Originally Posted by Simon_Picard
Go to your options and turn of assist targetting or something like that off. It is an option.
Thanks!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
03-27-2010, 03:49 AM
Quote:
Originally Posted by faithborn
this is a good answer, but I would like to add that you may need to either hit f1-5 several times or hold it down, otherwise sometimes it can freak out and retarget something (this is prudent in case you're using autofire or weapons are in the middle of shooting)
You may also have to set target attacker to off in options as well. If set to on this causes you to automatically target any hostile that fires on you.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
03-27-2010, 04:42 AM
Thanks guys I have changed the setting on my controls and it works great now!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
03-27-2010, 08:21 AM
I had the same problem...thx.

But one more thing: Is there any way to bind a key to "Target Self". Can't find that option anywhere. The default key is F1 but I use F1 - F10 for my second row in the power tray.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 02:16 AM.