Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Ship Weapons/Shields nerfed?
03-23-2010, 07:11 PM
All of a sudden; my MK X weapons' DPS is listed at about 2/3rds of what it had been and my Shields' rating and regeneration are listed at about 1/3rd of what they were previously.

I'm 99% sure this happened today.

Has this happened to anyone else?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
03-24-2010, 05:42 AM
All my stats have remained as they were on my vessels. (cruiser/escort)
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
03-24-2010, 06:11 AM
Quote:
Originally Posted by ForsettiTyr
All of a sudden; my MK X weapons' DPS is listed at about 2/3rds of what it had been and my Shields' rating and regeneration are listed at about 1/3rd of what they were previously.

I'm 99% sure this happened today.

Has this happened to anyone else?
Did you buy a new ship? I've read there is a display problem when you switch from science to cruiser or escort (who have less shields with the same system).
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
03-24-2010, 08:36 AM
It's the so called Runabout-Tooltip-Bug (what is a missleading name) what means you get always a wrong tooltip-info with values from your last buyed ship. But it's only a tooltip display error, not a real bug and it's fixed on Test server afaik.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
03-25-2010, 10:19 AM
Thanks for the info everyone. I purchased a runabout shortly before I noticed the problem.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6 I am also having this issue
04-04-2010, 04:57 PM
I am playing a science officer that is using a science vessel.

I was off the server for about 3 weeks came back on and did my updates about a week ago March 26, and noticed that in ship VS ship combat that I was having issues with my regenerative shields (I kept getting destroyed against enemies that I use to destroy with ease before).

So having this issue I decided to purchase a new shield array. I purchased the carraivant shield array that had a capacity of (about) 4800 an a regn. rate of 107, The best I could buy. As soon as they were added to my inventory the capacity dropped to 3850 and the regn. dropped to 72. This is about a 31 % decrease.

I was not very happy with this at all but once I equipped them I was able to finally survive in combat. I have all of the shield efficiency skills up to my level LC 9 and shield regn. consoles, and I run with 100% power to shields.

This issue has put a bad taste in my mouth over this game. Science vessels I was sure to have the best shields in the game even in the descriptions they are suppose to "have the most advanced shields in star Fleet", but this leads me to believe that this statement is now wrong.

Any way this is my thoughts.

Edit - I do not have a runabout.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
04-05-2010, 12:21 AM
If you're running with 100 to shields then your biggest problem is probably not killing things fast enough since you won't have much power to weapons. Try setting shields to 50. More than that is a waste for the most part. Put some in auxiliary, and the rest into weapons. That way you'll kill about three times faster and thus take three times less damage.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
04-07-2010, 10:46 AM
Quote:
Originally Posted by MustrumRidcully View Post
Did you buy a new ship? I've read there is a display problem when you switch from science to cruiser or escort (who have less shields with the same system).
It happens when you buy a second ship period. Happened to me when I moved my gear from my BC to a Carrier for a test run. When I view the same shields with my other account with only one ship, I see a completely different, higher, value now.
the Dev stated it's only a display poroblem, it doesn't actually lower the capacity of the shield, no way I know of to verify that, tho.
They fixed it on the Tribble server, not sure when they'll implement the fix to the Holodeck server.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 07:33 PM.