Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Boarding party
04-18-2010, 04:00 PM
Please bring back the use of boarding party for enemy ships to use. That was such a awesome skill and I had a blast trying to "fight" off the boarding ships. Also it gave me a use for tactical teams/security teams.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
04-18-2010, 04:03 PM
they were bugged as hell
completely disabling ships for 15 minutes and what not....

i expected them to get fixed but they were removed completely.

I didn't realy miss them.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
04-18-2010, 04:21 PM
Quote:
Originally Posted by Z3R0B4NG View Post
they were bugged as hell
completely disabling ships for 15 minutes and what not....

i expected them to get fixed but they were removed completely.

I didn't realy miss them.
speaking of which how about buffing/fixing the player ability boarding party. the shuttles always get stuck in the middle of space doing nothing.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
04-18-2010, 06:38 PM
I believe the Borg use boarding parties now. Although I have not noticed any shuttles, just the green person silhouette that shows up on your ship. Now I'm sorry I got rid of that BOFF that had the security team that I never used... oh well. If they land your ship systems can all shut down on you, not as long as it was in beta where your ship could be shut down for up to an hour or more.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
04-18-2010, 06:39 PM
Quote:
Originally Posted by deadtorius
I believe the Borg use boarding parties now. Although I have not noticed any shuttles, just the green person silhouette that shows up on your ship. Now I'm sorry I got rid of that BOFF that had the security team that I never used... oh well. If they land your ship systems can all shut down on you, not as long as it was in beta where your ship could be shut down for up to an hour or more.
I always wondered what the borg insignia was on my ship.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
04-18-2010, 06:40 PM
Quote:
Originally Posted by Z3R0B4NG View Post
they were bugged as hell
completely disabling ships for 15 minutes and what not....

i expected them to get fixed but they were removed completely.

I didn't realy miss them.
Yes, they were bugged. They need to fix them and put them back in game.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 09:02 AM.