Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 [BUG] Exchange issues
05-06-2010, 05:51 AM
Since the S1.1 update, the Exchange Search function is not working properly. Tried on Sol Dock, Mem.Alpha, DS9, K7 and an Omega Battle Group interfaces, and I've found out the following issues on all of them
  • Max limit of 400 items - when searching for a common enough items, this doesn't display ALL of them. Let's say I want to find a Bridge Officer who has Reverse Shield Polarity III skill. They are usually among the most expensive ones, thus at the end of the list sorted by price. However, first 400 slots are filled with less expensive BOffs, meaning the best are not available. I've tried the "engineer" filter, still more than 400 results. Only when filtered with eg. "human engineer", I can access the best ones. But this is very tedious, searching by every race, and still doesn't solve other possible items which are not filter-able as the BOffs. We either need the Sort by Price - both ascending and descening, or 400 limit gone.
  • When searching for food items, typing exact food name, All categories, Any rank, Any quality, only the most expensive few are returned. And I'm talking EXPENSIVE here - 400k for an Jumbo Romulan Mollusk, minimum! Only when I select "Lieutenant" in the rank drop down, I get more cheaper ones (going by previous example - there were Mollusks for cca. 30k).
  • For many items, rank selector is mandatory. No longer can we find level-banded stuff like consoles, weapons, shields etc. by leaving it on Any rank. Instead, we need to select the exact rank to work. Typing the Mk designation doesn't help either. Looks like a filtering issue.

While I approve the long-awaited sorting and scrolling options, it has obviously introduced new bugs and broke things which were working before the S1.1 update. It has made browsing the exchange tedious, awkward and sometimes downright misleading.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
05-06-2010, 07:56 PM
I agree the searching and filtering on the Exchange needs work. I wanted to add to the list of issues from Lord_Calidor:

* I posted for sale the item "Critical Components", and then tried to find my posting as a buyer. I searched with the selection "Ship Devices" and my listing for the Critical Components did not appear.

Ideally, just as on the auction website Ebay, once you post an item for sale you should be able to search for it as a buyer and call it up to confirm that the listing was posted properly.

I also typed in the name "Critical" in the search filter but my posting did not appear.

I noticed the Critical Components item is categorized as "Common Inventory", so perhaps a "Common Inventory" filter item needs to be added to the list of searchable categories on the exchange?

Cryptic developers, if you want a robust exchange you should take some time to review eBay's functionality for posting and searching auctions and then ensure the STO exchange gives a player similar features.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
05-06-2010, 08:06 PM
Update: the search is definitely limited in that it's limited to only 400 items. I posted a standard hand phaser for sale at 100 while the maximum price was 60 for the first 400 items returned in search, and never found my phaser. I then reposted the hand phaser for sale at 59, and then my listing appeared in the initial set of 400.

When I sort by Item Name it appears the price is no longer constrained, though the entire list of items available is cut off at the 400 mark.

Also, when I searched by name my Common Inventory item would still not appear for sale on the exchange (item Critical Components).
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
05-07-2010, 08:42 AM
To add to this, filtering is definitely not working properly.

For example, if you search for "Engine Battery" under "All" items, it returns a small list of quite expensive engine batteries.

If you then change the item type to "Ship Devices" (click the relevant button) and search again for "Engine Battery", it returns a much bigger list of engine batteries and with much more reasonable prices too.

Note that this is not limited to engine batteries, I just used that as an example. It seems that when searching the exchange, you need to specify the type of item you are looking for: ship device, ship weapons, ground device etc in addition to entering some search text, otherwise you get a very small sub set of what is really on sale for the item text you searched on.

I /bugged this last night but don't have the log number to hand now.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
05-07-2010, 08:55 AM
Quote:
Originally Posted by DogsBody
To add to this, filtering is definitely not working properly.

For example, if you search for "Engine Battery" under "All" items, it returns a small list of quite expensive engine batteries.

If you then change the item type to "Ship Devices" (click the relevant button) and search again for "Engine Battery", it returns a much bigger list of engine batteries and with much more reasonable prices too.

Note that this is not limited to engine batteries, I just used that as an example. It seems that when searching the exchange, you need to specify the type of item you are looking for: ship device, ship weapons, ground device etc in addition to entering some search text, otherwise you get a very small sub set of what is really on sale for the item text you searched on.

I /bugged this last night but don't have the log number to hand now.
This is probably due to the issue on launch that had a lot of items put under the "Commmodities" categories, and when the exchange went through it's first revamp it was mentioned that if you wanted items under the proper category heading you'd have to re-post your items up for sale.

Here's the Release notes on it:


Quote:
Fix many items that were incorrectly being put into the Commodities category in the Exchange. Items will need to be removed from the Exchange and re-added for them to show up in the correct category.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
05-07-2010, 09:00 AM
Quote:
Originally Posted by Valdure
This is probably due to the issue on launch that had a lot of items put under the "Commmodities" categories, and when the exchange went through it's first revamp it was mentioned that if you wanted items under the proper category heading you'd have to re-post your items up for sale.

Here's the Release notes on it:
Thanks but wouldn't that mean you find less when searching (correctly) under "Ship Devices", than when just searching for "All"? If something is mis-categorised as a commodity, it should show under all items yes but not under "Ship Devices", that is the opposite of what is happening.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
05-07-2010, 09:28 AM
Quote:
Originally Posted by DogsBody
Thanks but wouldn't that mean you find less when searching (correctly) under "Ship Devices", than when just searching for "All"? If something is mis-categorised as a commodity, it should show under all items yes but not under "Ship Devices", that is the opposite of what is happening.

I didn't mean that there isn't a bug with the search, I was just looking at the results and seeing a possible reason for the difference.
With your example the engine batteries searched for under 'All' would be the ones affected by the old setting (eg: flagged in the database under the old 'commodities' setting), and the ones properly tagged under Ship Devices show up when you search with the filter on.

The issue / bug would appear to be that the "All" setting isn't actually searching all of the categories.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
05-08-2010, 02:48 AM
OK, yes that sounds feasible, although I haven't confirmed that the few items found under "All" are not also found under "Ship Devices" as they are over priced and I've not paged through sufficient pages to see if they are in the list or not.

So whether or not there are still items incorrectly categorised, I think we can agree that the exchange search setting "All", doesn't work properly.

Thanks for your input. Now all we need is for Cryptic to fix it!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
05-08-2010, 03:58 AM
Yea my experiences verify all of the above, plus one:

Search for any specific item, it will probably not be there. I searched for a Multi-spectro scanner mk x, received no results (that alone suggests a bug), so I revised search to multi-spectro mark unspecified, and two items came up both Mk I. This happened with everything else I've searched for as well.

I have several Mk X consoles up for sale - no player can see them, and so no player will buy them, and there isn't anything the player can do to fix it. Massive bug. They do not appear when I search for them either.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
05-08-2010, 12:43 PM
anyone else have this issue where you search a item say Phaser beam array MK III nothing comes up and then you put 5 items on the exchange then do another search and nothing still shows up?

thats the problem im having
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 10:03 AM.