Lt. Commander
Join Date: Dec 2007
Posts: 120
The below happens with every ship I've flown. I run the game with just about everything maxed out.

Fullscreen
Right before warping into a system (during last loading screen) my FPS drops like a rock, and the closeup (warp in view) of my ship shows a lo-res model 99.9% of the time. Once the camera stops panning around the ship, my FPS instantly jump back up. Here is an example of a really bad lo-res model, the Cheyenne, I wince every time I see it. [image1] [image2]
Windowed Maximized
FPS Never drops, and the warp in closeup loads the hi-res model. However during regular play the screen tears as if v-sync was disabled. Perhaps v-sync doesn't work in windowed mode, I am uncertain, but my FPS stays capped below 60. Regardless I find it too distracting to play the game in this mode.
I've tried just about every combination of V-sync on/off/app controlled there is, as well as enabling triple buffering in both screen modes to no effect.

So basically I'd like to know which is to blame for this.
  1. Is it a bug with the game engine in Fullscreen?
  2. Is it my Nvidia GeForce GTX 285 Hardware?
  3. Is it my Video Drivers? Currently 185.85 (Yes, it is quite old)
I run WinXP Pro
Here are my Driver settings. [image] (Vertical sync is now set to application controlled for the time being)
Here are my in-game settings. [image]
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
05-27-2010, 08:37 PM
Updated driver to 197.45, no change.
Moved STO install to 10,000rpm Hard Drive, no change. Though I do seem to zone faster.

I've messed with the in-game graphics settings in just about every which way. Only thing I've noticed worth mentioning is if I set Shadows to Low my ship warps in invisible, only the feint red glow of the impulse engines are visible. The ship will then become visible in hi-res after the warp-in camera is done.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
05-27-2010, 09:13 PM
What are your system specs? Also, there should be an option under the video menu called troublehooting in the in game where you can see some other options, one being to remove the fps cap. Have you tried changing any of these settings to see if they help?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
05-28-2010, 12:52 AM
Quote:
Originally Posted by Xanatdul
What are your system specs? Also, there should be an option under the video menu called troublehooting in the in game where you can see some other options, one being to remove the fps cap. Have you tried changing any of these settings to see if they help?
So that is where those options were hiding, I totally missed that! I believe I disabled the FrameRateStabilizer & MaxFPS the very first day with slash commands, probably from the warnings /showFPS gives you about performance.

Here are those settings [Image].
  • WinXP Pro SP3
  • Intel Core 2 Duo E8500 (OC'd to 3.8GHz)
  • 2GB DDR2 Memory (FSB:DRAM 1:1)
  • Nvidia GTX 285, 1GB DDR3 Memory PCIE 2.0
Well I messed with all those settings in Fullscreen, and there was no change, garbage scow every time.

However, setting the max fps to 30 has stopped the tearing in Windowed Maximized! I didn't want to set it that low, but even trying it as a slash command the tearing didn't stop till setting it to 30. So far I haven't noticed any visual difference, seems pretty smooth (FPS is nearly always max, so far only drops down to 24-26 right after zoning, but doesn't last long). I'm damn thankful for this, not sure what the differences between Fullscreen and Windowed Maximized are besides v-sync.

I'd still like for it to work in Fullscreen. I still don't understand why it is always perfect in Windowed Maximized, and screwed up in Fullscreen.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
05-28-2010, 04:51 AM
Couple things come to mind...

-You tried messing around with the "Reduce file streaming" option?

-In the Nvidia control panel, what is your "Maximum pre-rendered frames" set at?

-Tried updating DirectX?

-Any HW monitoring programs or OSD's running?

Hardware wise the only thing I see that "might" be part of the problem is 2GB RAM. 2GB isn't much to work with now days IMO.

Edit: In that recent pic of yours, that looks like texture/model corruption, even at lowest settings it doesn't look THAT bad on my end. Have you tried force verify? If that doesn't do anything perhaps try reinstalling the game?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
05-28-2010, 07:41 AM
Yeah you might want to try reinstalling, see if that helps.

(EDIT} Also, I know this may sound strange but, it could be your OC CPU. It's rare, but there are games out there that are touchy when it comes to OC items. For example, Assassin's Creed for PC is really sensitive to anything overclocked and it causes the screen to tear, textures to fail, wireframes becoming visible, all sorts o' wierd. Just a thought.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
05-28-2010, 05:04 PM
Quote:
Originally Posted by Trekker88 View Post
Couple things come to mind...

-You tried messing around with the "Reduce file streaming" option?
Yes, no effect.
Quote:
-In the Nvidia control panel, what is your "Maximum pre-rendered frames" set at?
3 normally, but I did jack it up to 8 to see if it had any effect. I didn't notice anything, maybe I should try turning it off.
Quote:
-Tried updating DirectX?
Yes
Quote:
-Any HW monitoring programs or OSD's running?
No
Quote:
Hardware wise the only thing I see that "might" be part of the problem is 2GB RAM. 2GB isn't much to work with now days IMO.
Well I'm at my limit in 32bit WinXP basically. Along with the size of my video cards ram I could only add 1gb to the system, and I'd loose my dual channel mode. Plus the /3gb switch isn't all sunshine and rainbows. I'm waiting to go to Win7 with my next upgrade cycle.
Quote:
Edit: In that recent pic of yours, that looks like texture/model corruption, even at lowest settings it doesn't look THAT bad on my end.
Well it doesn't look that bad normally when I turn everything to it's lowest setting either, but still happens on the warp in. For that reason I am pretty sure my RAM is a non issue.

Normally you would never see this low (rock bottom) LOD for these models up close, they would only be used for viewing at an extreme distance. Something about Fullscreen mode tells my computer to display the lowest level detailed model when it absolutely shouldn't. As for it looking corrupted, I'm pretty sure the low level detail of these models it just poorly done. On a Galaxy class the low LOD is of much better construction. You can still tell it's the low poly model, but it keeps it's overall shape intact.

Quote:
Have you tried force verify?
Yes, before and after changing hard drives, and again just a few minutes ago.
Quote:
Originally Posted by Xanatdul
Yeah you might want to try reinstalling, see if that helps.
If force verify passes, is there really any need to re-download the entire 8gb's of the game?

Quote:
(EDIT} Also, I know this may sound strange but, it could be your OC CPU. It's rare, but there are games out there that are touchy when it comes to OC items. For example, Assassin's Creed for PC is really sensitive to anything overclocked and it causes the screen to tear, textures to fail, wireframes becoming visible, all sorts o' wierd. Just a thought.
Hmm, not sure if I'm willing to test that theory. I suppose I'd find out if it is the cause, but it wouldn't stop me from OC'ing. I don't have any such problems with other games, but I don't have Assassin's Creed. I'll consider it.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
05-28-2010, 09:46 PM
Quote:
Originally Posted by Grey_Ghost
If force verify passes, is there really any need to re-download the entire 8gb's of the game?
Couldn't hurt to try. It's just annoying.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 05:29 PM.