Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 starship-shadows flickering
06-13-2010, 04:28 AM
Good day,
first of all my system:

-Intel Core 2 Duo E6700
-Radeon HD 5850 with Catalyst 10.5
-Windows 7 64 Bit
-4GB Ram

in the video-menu, i set the overall-graphic-settings-bar on max-quality which includes the "High"-setting for shadows. but somehow, the shadows that are cast on the ship's hull (they are cast by parts of the ship itself like the warp-drive tubes) start to flicker as soon as i move the ship in any direction.

the only way to stop the flickering is to set the shadows on "Low", which isn't really an alternative in my opinion.

can somebody help me out?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
06-20-2010, 07:20 PM
I think it does this for everybody.....

I wish I could. I think it is a general game engine problem. My brother sees it and he has a new Nvidia card and I have a crossfire ATI....same thing.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
06-21-2010, 02:41 AM
not 100% sure but i do think its just how the graphics work..maybe its meant to look like your traveling though multiple light sources

I got annoyed with it enough that i just turned shadows off, it also means my fps stays high 50's even in very large scale battles or particle heavy maps
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
06-21-2010, 08:32 AM
Quote:
Originally Posted by NzFox
not 100% sure but i do think its just how the graphics work..maybe its meant to look like your traveling though multiple light sources

I got annoyed with it enough that i just turned shadows off, it also means my fps stays high 50's even in very large scale battles or particle heavy maps
Turn off the shadows, it's what I had to do as well. I've learned to live without the shadows on since the days of Neverwinter Nights original release.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
06-21-2010, 06:53 PM
I find that shadows are sketchy in a lot of games. They tend to clip through objects ( such as seeing the shadow of some guy on the roof of the building on the ceiling INSIDE the building ) and have a unnatural look to them.

Sometimes I turn them off, because they just don't match the artistic look of a game.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
06-28-2010, 07:35 AM
'k,
thanks for answering...too bad the shadows look that bad in the game....

but still, my brother told me that he hasn't seen any flickering so far, so i guess it is NOT a stylistic device....
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
06-30-2010, 01:37 AM
This happens to me as well. ATI Radeon HD 4870
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
07-09-2010, 03:12 AM
I had graphical glitches and flickering too. I checked the Option "force verify" at the game launcher option screen, so the game checks all game files on the next run. It took like 3 or 4 minutes at most and it solved this issue for me, the flickering is gone.

On a sidenote, I use a single geforce 280 GTX with the newest driver.


Salutations,
Dani
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
07-11-2010, 02:48 AM
Quote:
Originally Posted by Roukh
I had graphical glitches and flickering too. I checked the Option "force verify" at the game launcher option screen, so the game checks all game files on the next run. It took like 3 or 4 minutes at most and it solved this issue for me, the flickering is gone.

On a sidenote, I use a single geforce 280 GTX with the newest driver.


Salutations,
Dani
thanks Roukh that seems to work but the next day it's back again. Is there something wrong with the files?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
07-31-2010, 03:47 AM
It's because they use shadow mapping instead of shadow volumes, so the resolution of the shadows is limited by the resolution of the shadow map, whereas a shadow volume would have clean lines.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 03:28 AM.