Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Autoturret Glitch!
07-05-2010, 04:37 PM
Ok this is starting to bug me as i see more and more people doing it.
And its not really fair for Klings.

1. The auto turret will hit you when you are cloaked. Forget being cloaked around a ship with auto turret.
Your saying so what huh? its a tiny turret does tiny damage.

Not if the its on a SCI person with SCAN.

They notice the turret go off, BAM scan... and you get busted.

Cryptic you guys need to fix this.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
07-05-2010, 04:40 PM
The turret only has a 5km range, why the hell would you get that close and not already be decloacked? that's probably why no one has brought this up yet actually.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
07-05-2010, 04:42 PM
Quote:
Originally Posted by Gatness View Post
The turret only has a 5km range, why the hell would you get that close and not already be decloacked? that's probably why no one has brought this up yet actually.
i do a ton of hit and runs in a bop...

At first i didnt care... then i noticed sci guys with full impluse sweeping the area with auto turret.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 03:23 AM.