Lt. Commander
Join Date: Dec 2007
Posts: 120
So, this morning, I tried to login to Star Trek Online. It told me the server was down. Curious, I thought, because the website says it's up. So, I go to the website, and login, and, after find no reason that the server would be down, proceeded to the account section to make sure my account wasn't, say, stolen or anything. When I arrive there, I notice that not only has my debit card been removed from payment options, but my game apparently is longer tied to my account- as under products, it is not there. When I try to redeem the key steam gave me when I originally bought the game, it tells me the key has already been used (By me, the first time I used it, obviously.)
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
08-20-2010, 09:53 AM
Never mind- I got everthing fixed.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
08-31-2010, 02:38 PM
I'm now encountering a similar error once more- only, this time, while my subscription disappeared, my card data stayed, but my characters are no longer accesable from the account page- I fear they may have been deleted. After I found out that my account was not working, I clicked the demo button, in hopes of being able to attend a fleet event that was occurring. I fear this may have deleted my characters- as they were above the demo levels.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 05:31 PM.