Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 11
08-27-2010, 02:09 AM
I don't know how related this is, but since the update, I notice on ground missions that 'weird' objects appear in my skill-bar. I've had a holographic tribble and a few 'Focus Fire III' icons appear in the same slot on different missions right at the start - none of which I currently have on my Klingon toon. They aren't selectable.

And, yes, as a tac officer on a BoP, this 'yes, we know you have 300 engine batteries in your inventory - pick one and don't waste it!' bug is making PvP'ing a real chore...
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 12
08-27-2010, 05:43 AM
Also should mention and confirm what some others have said -- that after the match, the Combat Log actually says you activated the Engine Battery... even though you didn't (couldn't).

Lt. Commander
Join Date: Dec 2007
Posts: 120
# 13
08-27-2010, 09:15 AM
Well, I just swapped stacks after every usage, (Engine Batts), and that seems like a temporary workaround for now.


.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 14
08-27-2010, 10:13 AM
This is a blatant example of cryptic doing easy workarounds instead of fixing the heart of the problem. Their coding system totally violates every rule and its coming back to bite them hard. Instead of finding the heart of the problem the post a quick fix around the problem but then it corrupts the coding somewhere else in the game that was working fine 2 days before.

Me and my fleet have had numerous talks about this stuff. They take a working subroutine and copy and paste it all over the game instead of using a single copy that all areas of the game have to refer to. If you use a isolated subroutine that each aspect of the game that requires it can reference than it makes it a simple problem to fix. If teaming is busted it must be in the teaming subroutine. This means you have a small limited amount of code to review and fix. But from what i have seen the copy and paste that code to every part of the game that needs it. That means if exploration teams are broken it may not be in the teaming routine at all it could be in how the exploration area access it. Long story short you have to go through every line of code in the game for exploration areas instead of a small subroutine, Which means weeks or months of line by line searching to fix the issue. Meanwhile players are screaming for a fix on something that wasnt broke before.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 15
08-27-2010, 03:38 PM
Happend to me and fleet m8 too.
Cryptic, this is game braking, plz, fix it before weekend!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 16 Game Breaking
08-27-2010, 03:58 PM
I wish the focus on new content would be HALTED immediately and all dev teams would be put to work on FIXING the game we have. After that, well go ahead and make additions but JEEZ, you can't icing a cake while it's baking.
I don't even care if they went back to the original game and started over. At least it was playable then. I mean really, what are my options? STFs are unbalanced, nearly impossible to accomplish and therefore NOT ENJOYABLE. Teaming in exploration missions JUST-DOESN'T-WORK. Now consumables are bugged. What next? Our toons get deleted randomly?
Oh yes, PVP is fixed.
WOO-HOO
I despise PVP. If I wanted to PVP, I would reinstall Quake 3, Half-Life or a myriad of other shooters and go head to head with 12 year olds.
STO is more than this....or at least it used to be.
I hope it will be..Fully Functional.. soon.

Arnon
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 17
08-27-2010, 05:05 PM
Delaateeee
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 18
08-27-2010, 09:05 PM
This bug also happened to me.

The only way I was able to resolve the issue, was unequiping one Stack of Batteries and equiping a different stack of the same item. But it is very annoying to have to do that after EVERY use.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 19
08-27-2010, 09:19 PM
Quote:
Originally Posted by KRAKEN73501 View Post
This is a blatant example of cryptic doing easy workarounds instead of fixing the heart of the problem. Their coding system totally violates every rule and its coming back to bite them hard. Instead of finding the heart of the problem the post a quick fix around the problem but then it corrupts the coding somewhere else in the game that was working fine 2 days before.

Me and my fleet have had numerous talks about this stuff. They take a working subroutine and copy and paste it all over the game instead of using a single copy that all areas of the game have to refer to. If you use a isolated subroutine that each aspect of the game that requires it can reference than it makes it a simple problem to fix. If teaming is busted it must be in the teaming subroutine. This means you have a small limited amount of code to review and fix. But from what i have seen the copy and paste that code to every part of the game that needs it. That means if exploration teams are broken it may not be in the teaming routine at all it could be in how the exploration area access it. Long story short you have to go through every line of code in the game for exploration areas instead of a small subroutine, Which means weeks or months of line by line searching to fix the issue. Meanwhile players are screaming for a fix on something that wasnt broke before.
If this is the case, it would be ironic that they did it to save time, yet it will cost them so much more time... and us misery... and them, money!

Lt. Commander
Join Date: Dec 2007
Posts: 120
# 20
08-27-2010, 09:27 PM
Well we all know where Cyrptic's Priorities are at, They rather work on the Character selection screen so your Character is on a transporter pad, and we would like to take the ships out side of SOL station cause they are too big in scale, and fix that.


So you might be waiting about 2weeks for your Hypos and Ship Batteries to be fixed. well maybe a month.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 06:45 PM.