Go Back   Star Trek Online > Feedback > PvP Gameplay
Login

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
Pairadocks started a thread with this topic, however, I wanted to start one with a different title to ensure that Cryptic sees the actual problem.

It doesn't appear to be a bug, it has affected each pvp'er. Without the unlimited use of devices, (2 per match is not enough) pvp is just not fun, but frustrating. A good pvp'er will go through dozens of each per match.

Please restore the previous unlimited use of such devices.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
08-27-2010, 04:22 AM
If this is not a bug this is a big nerf for BoPs/escorts.After the RSP I am basically dead without an engine battery.
(battlecloaking successfully with brace for impact and aux to SIF II is like winning the lottery)

For my galaxy-r cruiser this is not a big problem but for my BoP this is a really deadly bug.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
08-27-2010, 04:33 AM
this HAS to be a bug....

Tacs are helpless on ground without their hypos...

And it appears to be somewhat random... somtimes some people can pop more than one hypo/battery...
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
08-27-2010, 04:45 AM
Just played an arena on my cruiser and I used 3 engine batteries without problem so it was probably just a bug.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
08-27-2010, 10:29 AM
I hope its a bug because the 2 minute cool down on batteries was more than enough to prevent spamming before and this bug will have untold consequences on the already <edited> KLingon faction since some of us can't get our rewards any other way than pvp.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
08-27-2010, 11:14 AM
Ah it feels great to be a medic using a Bat'leth right about now. I always thought hypos/charges/batteries were overrated. New video: http://www.youtube.com/watch?v=DyRauDmyxcs
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
08-27-2010, 12:05 PM
Catch 22 here...
Devs are either not aware of this bug...and it is a bug, as different people get affected different ways of this...and you gotta post to hope it can be fixed because Cryptic does not communicate.
Problem is now, all ground engineers I have met in matches the last day have swapped kits to spam WM knowing how hard it is to counter now.
As usual, post a bug, and the exploiters come out of the woodwork.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
08-27-2010, 01:12 PM
Quote:
Originally Posted by Kilawpilath View Post
The issue is also affecting space..

The way to resolve the issue for now, is to constantly Unequip and reequip the Item.
Since I posted this some place else, and since this is another topic concerning the same thing.. I'll reply my post from the other topic..
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
08-27-2010, 06:46 PM
Must be a bug.

There has also something changed, before the patch when using an expendable it would leave the equipped stack alone and take one from the inventory.

So lets say I have 60 hypos, 20 equiped, 40 in inventory, using 2 would reduce the ones in inventory to 38, but leave the 20 equipped alone -- before the patch.

After the patch, first hypo is taken from inventory, i can see the stack number update there. Second hypo however doesn't update any stack numbers at all, its as if i didn't use one at all. As soon as i move the 20 stack from the equipment slot to inventory however it updates to 19, so the second hypo seems to have been taken from the equipment slot, but didn't update the stack number -- this behavior seems to be new since the patch and could be related to the bug.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
08-30-2010, 01:54 AM
it is not a per match thing, what ive noticed is that after the 2 uses if you unequip it then re-equip it you get another 2 uses out of it. it cant be anything other then a bug and i say this because it doesnt remove the items from you until you unequip it. give it a look see next time.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 12:24 AM.