Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Mission destiny broken?
09-01-2010, 10:12 AM
So I've leveled up my Tac character to cmdr 10, completed the mission where i defend quo'nos from the fek'lir, and eagerly accepted my new mission, destiny. i went to Quo'nos & talked to the chancellor who sent me to Sanek, to seek the blade of Kahless. i get to Sanek & nothing. Nothing happens. i just sit there in space parked near the planet in the sector map. i dont get a dialog box to enter it. I am bummed, because i did this mission with my main toon, who was a BG engineer when this mission came out, & i was really looking forward do doing it with a char of the proper level. Does anyone else have this problem?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
09-01-2010, 10:23 AM
Quote:
Originally Posted by amidoinitright View Post
So I've leveled up my Tac character to cmdr 10, completed the mission where i defend quo'nos from the fek'lir, and eagerly accepted my new mission, destiny. i went to Quo'nos & talked to the chancellor who sent me to Sanek, to seek the blade of Kahless. i get to Sanek & nothing. Nothing happens. i just sit there in space parked near the planet in the sector map. i dont get a dialog box to enter it. I am bummed, because i did this mission with my main toon, who was a BG engineer when this mission came out, & i was really looking forward do doing it with a char of the proper level. Does anyone else have this problem?
Well, I noticed many problems with this mission on tribble and then after it came out. There seemed to be a problem with it cycling, continuing, or anything else if I had ANY other active quest.
I would recommend dropping every other quest you have. Pick that quest up from the Chancellor (this is after of course you leave the system so it resets), and do that whole mission before you get or do anything else. See how that goes. That worked for me, I dunno, but it seems to me that they did very little bug squishing on the Klingon side before 2.0 went live....
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
09-01-2010, 11:31 AM
thanks i'll try that
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
09-08-2010, 11:13 PM
I just did the mission and had no problems.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
09-09-2010, 06:08 AM
Did you go out into the first city and talked with the historians?

I was stuck there as well (or so I thought) but once I had talked with the guys outside, I progressed with no problem.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
10-24-2010, 05:04 AM
The first city? You mean Qo'noS?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
12-09-2010, 01:01 AM
I got the same problem, no Breen Attack force.

Wish they'd fix the broken stuff before they decide to add more all the time.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
12-09-2010, 01:11 PM
This is odd. I have never had a problem before doing this mission. Do you think the update borked it?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
12-09-2010, 10:20 PM
Quote:
Originally Posted by MelineAaele View Post
Did you go out into the first city and talked with the historians?

I was stuck there as well (or so I thought) but once I had talked with the guys outside, I progressed with no problem.
this was the problem, thanks for the help.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
12-09-2010, 11:58 PM
I talked with the historians, twice! (after I dropped and restarted it.)

I did not have time to try it today as I tried to PUG Infected.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 04:43 PM.