Lt. Commander
Join Date: Dec 2007
Posts: 120
Ok i had a bug details of which can be found HERE

I logged in game support ticket, and they said that they where unable to reproduce the issue and nothing would be done, however there was a known issue with vendor bugging was resolved. And that i should post feedback in the feedback forums.

So can we please get a confirm option on all emblem exchanges, and perhaps make the default multiple purchases bar set to 0 instead of the maximum of 100, so there is no way one can trade 100 emblems unintentionally. At least put a retrieve tab in the emblem vendor so i can undo unwanted purchases, like what happens if you sell something accidentally. This way only items bought at the vendor can be reversed and not marks from missions.

And as by this PICTURE shows the purchase and cancel button are millimeters apart it is way to easy to miss click
resulting in Irreversible purchase that cant be undone , even though im sure when i clicked it the first time on my Klingon toon the screen didn't show, and i just lost 100 emblems straight away


Further on i would like to relay how disappointed i am by supports response to my issue. As by my SCREENSHOT and report it was clear that i had the emblems in the first place, and only wished to purchase a few.

All i wanted was the 100 marks converted back to the emblems i had. Instead i get this all sales are final push off and thanks for playing star trek online spin. Whatever happened to the customer is always right?

Well i lost 100 emblems here's hoping something gets done to fix it, before it happens to someone else.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 06:05 AM.