Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Vet day counter bugged
11-09-2010, 11:36 AM
My subscribtion was made ad start, 4 weeks before start to be exact, but for some reason it says I have only had a 295 days active account that isn't true, what is going on, have anyone else experianced this?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
11-09-2010, 11:58 AM
The date is based on Feb 2nd. or an earlier date that you purchased one of the pre-order extended subscriptions before the game launched. Those who didn't start until Feb 2nd (launch day) won't get their 300 day reward until the end of November. Only early subscribers are getting it before the end of the month: when based off of when you purchased your pre-order subscription.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
11-09-2010, 12:10 PM
As I already said I got my subscribtion 4 weeks before the first launch of Star Trek Online, that's whay I dan't understand why I only have 295 day on my counter.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
11-09-2010, 12:18 PM
Quote:
Originally Posted by The_Handler
As I already said I got my subscribtion 4 days before the first launch of Star Trek Online, that's whay I dan't understand why I only have 295 day on my counter.
The earlest anyone can get it is on November 9th, today, and that's assuming you purchased your LTS on Jan 14th (the first day it was offered): Nov 9th is 300 days from Jan 14th. For each day you purchased it after Jan 14th 1 day gets added on to the date. Someone who started playing, and paying, on Feb 2nd (launch day) will not get their Vet Reward until Nov 28th. Based on the fact that you have 4 more days it would be assumed that you purchased your LTS around the 18th, and so won't get your Vet Reward until the 13th.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
11-09-2010, 01:09 PM
This is still strange, for I was one of those that got my 100 day vet reward first along with some other people, but now I'm getting it after those same people, that doesn't make sense. I I notced I made a misstake, it wasn't 4 days but 4 weeks before launch, so I should have gotten my vetran reward by now I didn't, so something is wrong.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
11-09-2010, 01:44 PM
The only people who are getting it early are the Life Time Subs, eg those with the fancy blue forum names.

At the 100 day mark the account server had made a few mistakes as to how long people had subbed, I belive it was taking closed & open beta and head starts into account when it should't have.

To solve the issue, rather then take away the 100 day award from those who should't have had it yet, cryptic just froze all the effected ingame subscription counters until the actual time caught up. During this time the only accreate measure was the counter on the web site.

Hope this helps, I only found out about the freeze as mine stayed frozed and told me I had 175 days subscription time for 3 weeks.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
11-09-2010, 01:55 PM
I made a lifetime subscribtion, I was in beta and I should have gotten the vet reward as it is over 300 days since I made my subscribtion... it feels like I'm repeating myself over and over, but this is getting stressing and annoying, anyone know where to report this in the right area?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
11-09-2010, 02:18 PM
Quote:
Originally Posted by The_Handler
I made a lifetime subscribtion, I was in beta and I should have gotten the vet reward as it is over 300 days since I made my subscribtion... it feels like I'm repeating myself over and over, but this is getting stressing and annoying, anyone know where to report this in the right area?
I think you're repeating yourself because you're not bothing to read what's being told to you. Vet Rewards are not figured from Alpha, Closed Beta, Open Beta, or Headstart play time. They are figured from Feb 2nd or from the day you purchased an LTS; whichever comes first. LTSs were first offered on Jan 14th. That is the first day you could purchase one. If you purchased one on Jan 14th you would get your 300 day Vet Reward today, as today is 300 days from Jan 14. If you purchased your LTS on Jan 15th you get your Vet Reward tomorrow, if you purchased one the Jan 16th you'll get your Vet Reward the day after tomorrow, and so on down the line. All LTS members don't get it on the same date. They get it based on the day they bought the LTS. What is so hard to understand about that?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
11-09-2010, 02:44 PM
I'm having the same problem...made a few tickets but I never did get it fixed. I got LTS when it first came out...yet it says I've been playing for 279 days (I think). 100 day I got on time, 200 day was about a week or two behind and now 300 is over three weeks.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
11-09-2010, 02:45 PM
Quote:
Originally Posted by The_Handler
I I notced I made a misstake, it wasn't 4 days but 4 weeks before launch, so I should have gotten my vetran reward by now I didn't, so something is wrong.
I think you've made more then 1 mistake. LTSs were not offered 4 weeks before launch. They were offered 19 days before launch.

As far as being one of the first to get it before, keep in mind all the dates were wrong on the 100 day mark. Everyone was complaining about them at the time. Cryptic fixed the dates and adjusted everyone from launch day or from the day they purchased their LTS.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 07:28 PM.