Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 antiproton weapons
03-12-2011, 08:44 AM
Just got some antiproton cannons from bgo, but i cant equip them on my escort, is there something i should know?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
03-12-2011, 08:51 AM
just checked, is only ones from bgo that wont equip, is there some requierment need for them, or is this a known bug?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
03-12-2011, 08:56 AM
You have to tell us more.

Are you trying to mount cannons as aft weapons? No cannons can be aft weapons. I believe the same goes for beam banks. But beam arrays and turrets can go fore or aft.

Did you buy them from the Exchange at BGO or from the U.S.S. Montgomery Scott or the U.S.S. Thomlinson? If Mark 11 from the Exchange, you can buy them but not use them if you are RA lower half.

If you are an RA lower half, and bought Mark 11 weapons, only RA upper half or VAs can use Mark 11 weapons.

You said escort, but what is the specific ship? Not to doubt you, but if you are trying to put heavy cannons on a ship that's not an escort, you can't do that.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
03-12-2011, 08:59 AM
i am a va got weapons from montgomery scott, its a escort tried all three my escorts, as said i can mount crafted antiproton cannons no problem, i allready filed a ticket.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
03-12-2011, 09:16 AM
found answer on google, for some reason need be in space to equip them
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
03-12-2011, 09:17 AM
I remember something like this happening to me before with AP cannons.

Couldn't equip the cannons on a ground map, but had to be in a space map inorder to equip them.

Dont know if this helps or not.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
03-12-2011, 09:22 AM
Quote:
Originally Posted by pyro1
found answer on google, for some reason need be in space to equip them
Oh yeah, that's an old bug. I thought they fixed that.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
03-12-2011, 03:28 PM
It was fixed, I can confirm that, it has also been unfixed, I have confirmed that too.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 07:40 PM.