Lt. Commander
Join Date: Dec 2007
Posts: 120
Mission ST-HSONJMPNL

The worst of all worlds.

map - alternate vulcan

I have set up two kill encounters next to each other in a kill all situation. One is a sphere and one is a cube.

for some reason the cube now only appears once your ships reaches the waypoint, (both in testing and when published) then it just appears next to you. At first when i made the mission it was ok and the ship spawned about 25k away but now it will only appear when you hit the waypoint. Im not sure what i have done to set this situation up.

i have not set any triggers on the Cube and im not using a reach marker. It is just a normal kill encounter and set to appear immediately and im not sure why its not appearing sooner.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
03-30-2011, 10:22 AM
Don't put a reach Marker tool before an enemy contact. That indicates a De-cloak feature.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
03-30-2011, 11:54 AM
I'm planning on looking into this today, Captain Revo.

(I wanted to last night but blah blah technical difficulties.)
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
03-30-2011, 12:01 PM
thank you.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
03-30-2011, 01:49 PM
So I'm still looking at it, but I'm wondering if that's just how this npc group works... Did you ever see the cube appear from the start of map?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
03-30-2011, 03:34 PM
i have tested other cubes in this mission and others and they all work fine.

ive noticed something however. now remember i have set this up as a kill all encounter and i think that is part of the problem.

the first objective is to destroy the cube (although the cube is positioned further way than the sphere so most people would complete this objective second).

the second objective is to destroy the sphere (but again its the first one you reach) this objective also has a dialogue box attached to it after you destroy the sphere.

now if you kill the sphere first, and read the dialogue then the cube does not spawn until you hit the way point. it then spawns about 1k away from you.

if however you bypass the sphere and go directly to the cube then it spawns normally from about 25k away. destroying the sphere first for some reasons seems to hamper the cub's ability to spawn at the correct distance.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
03-30-2011, 03:57 PM
Ok i have solved the problem but im not 100% what the cause of the problem was.

i said that the cube was task 1 and the sphere was task 2 on your task tracker but you would have to face the sphere before you faced the cube because that was their location on the map.

by simply swapping their locations on the map so you encounter the cube first fixed it.

i think that completing task 2 first was causing task one not to spawn correctly.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
03-30-2011, 04:17 PM
another update.

whilst switching them around seemed to work, it then made two npc contact freighters (who were near the sphere) only to spawn after i had reached the marker, just like the cube was.

i moved the freighters just to the left a bit of where the problem was and it looks ok now.

it almost seems like the actual map is bugged for that area just to the right of where the freighters are now causing ships not to spawn correctly regardless of whether they were part of the objective.

this is probably getting very confusing right now. ill try and confirm whether the vulcan map itself is bugged tomorrow. ill try and set up some ships spawns there to see if the area itself is the problem.

as of right now though the mission itself works.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
03-31-2011, 02:19 PM
Thank you for all the updates.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
03-31-2011, 03:22 PM
no problem, im not sure much of it makes sense.

ive not encountered the problem again and the misison seems to be working now and i cant re-create it. if i encounter it again ill be sure to update the thread.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 12:52 PM.