Lt. Commander
Join Date: Dec 2007
Posts: 120
Greetings Captains!

We will be bringing down Star Trek Online on Thursday, May 19th from 3:00 AM to 5:00 AM PDT (10:00 AM to 12:00 PM UTC) in order to perform maintenance and apply a new patch. We will update this thread once the maintenance has been completed.

Thank you,
The Star Trek Online Team
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
05-18-2011, 11:51 PM
umm... did u guys start the maintenance like, 5 hours early??? cause i havent been able to sign on for about 3 hours now.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
05-19-2011, 12:14 AM
looks like u did. my .exe file only says PATCH instead of engage or start or whatever it is normally... why wouldnt u tell us???
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
05-19-2011, 01:39 AM
I don't think they have started early because I've just signed in with no problems
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
05-19-2011, 03:26 AM
Quote:
Originally Posted by andro21 View Post
looks like u did. my .exe file only says PATCH instead of engage or start or whatever it is normally... why wouldnt u tell us???
This sounds like something on your end andro21.

There is an option to called "Force Verify", wich is under the options in your launcher. Try that. You might have a corrupted file...

Good luck getiing STO back up and running.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 07:25 PM.