Lt. Commander
Join Date: Dec 2007
Posts: 120
I created a second account for my son using a retail key and my trial key. The trial period for this new account has elapsed and my account has been charged the $15 monthly fee. However, I did not receive any of the bonus aitems associated with this account. I placed a ticket for this issue over a week ago and it's still had no response (else I wouldn't have been posting here). Please help!
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
07-18-2011, 04:46 PM
Did you go to My Account and to the Referral Program tab? You have to type in your son's email and it will send the referral key for him to activate his trial account. Any old trial account won't work to get the referral bonuses. The photonic tribble will be granted to you when he activates the referral and gets the game. The photonic bridge officer will be granted when you purchase one or more months of subscription. Lifetime Subscriptions should automatically give you the photonic bridge officer, but I am not sure.

I would not count on it getting fixed. I have 2 referrals in my Referral Program tab. One says redeemed under Key and Billed under Status and the other has the actual key for under Key and Offer Cancelled for Status. Both have a date of May 2010 for Date Sent.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
07-18-2011, 06:20 PM
Yup I did that...no bonus items...

I think what irritates me most is their customer service has ignored my request..
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
07-18-2011, 06:50 PM
Quote:
Originally Posted by Tegashi View Post
Yup I did that...no bonus items...

I think what irritates me most is their customer service has ignored my request..
Try the Live billing chat on the Atari STO support page. (Since it involved a subscription payment, it is a billing issue of sorts.)
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
07-19-2011, 04:36 AM
I'll have to do that. They've closed my ticket with some canned response about Season 4.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
07-19-2011, 04:59 AM
just to confirm you have checked the c-store under special unlocks or what ever the tab is called, as that is where you claim it from?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 7
07-19-2011, 05:51 AM
Quote:
Originally Posted by Captain_Revo
just to confirm you have checked the c-store under special unlocks or what ever the tab is called, as that is where you claim it from?
Yup. I've looked there...nothing
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 8
07-19-2011, 05:17 PM
Well, Customer Service refuses to help me with this one...
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 9
07-19-2011, 05:52 PM
did it actually charge your card? Remember, the box comes with a free 30 days, so even though you enter your CC info when you set up the sub, it doesn't actually charge the account until the end of the 30 days. check the Referral Program page on your account settings for the main STO site, that tells you the progress of any codes you sent out.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 10
07-20-2011, 04:21 AM
Quote:
Originally Posted by ACES_HIGH View Post
did it actually charge your card? Remember, the box comes with a free 30 days, so even though you enter your CC info when you set up the sub, it doesn't actually charge the account until the end of the 30 days. check the Referral Program page on your account settings for the main STO site, that tells you the progress of any codes you sent out.
Yep. I was charged $14.99
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 04:38 PM.