Go Back   Star Trek Online > Feedback > PvP Gameplay
Login

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 21
08-10-2011, 08:05 AM
Quote:
Originally Posted by ppumaht View Post
theres no bug there. shockwave the extender and the buff AND animation will go away.
Yep, this works for me everytime. But I always make sure to have the Extender 2KM
or closer before I hit shockwave, because there is the chance that they move out of the 3KM range before it actually hits them.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 22
08-10-2011, 08:21 AM
Quote:
Originally Posted by ppumaht View Post
theres no bug there. shockwave the extender and the buff AND animation will go away.
Thats what I was getting at I was the extendee not the extender. My healer got hit with 2 PSW at point blank and my ship still had the ES buff still on it but the graphic was gone.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 23
08-10-2011, 08:26 AM
Quote:
Originally Posted by Captain Data
Thats what I was getting at I was the extendee not the extender. My healer got hit with 2 PSW at point blank and my ship still had the ES buff still on it but the graphic was gone.
Maybe he was immune to stun. Did he have Aux2Damp or stun immunity from an earlier stun active?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 24
08-10-2011, 09:11 AM
sniped for redundancy
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 25
08-10-2011, 10:05 AM
Quote:
Originally Posted by Captain Data
Thats what I was getting at I was the extendee not the extender. My healer got hit with 2 PSW at point blank and my ship still had the ES buff still on it but the graphic was gone.
Quote:
Originally Posted by Vampir888 View Post
Maybe he was immune to stun. Did he have Aux2Damp or stun immunity from an earlier stun active?
maybe this, or something else-

i know theres no bug though. if the extender gets stunned the es goes away and then there's stun immunity and all that fun stuff.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 26
08-10-2011, 11:02 AM
Quote:
Originally Posted by Captain Data
Thats what I was getting at I was the extendee not the extender. My healer got hit with 2 PSW at point blank and my ship still had the ES buff still on it but the graphic was gone.
Maybe it was lag. I was point blank PSWing two players at different occasions, but never got the stun on them. I'm talking about right on them. They had no Aux to ID or Omega either. Or maybe they did and the dumb UI didn't show it. lol.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 27
08-10-2011, 12:55 PM
My healer doesn't like Aux2ID because it shares CD with Aux2Sif. SO I don't know.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 28
08-10-2011, 07:08 PM
Yeah and I was just a match where I was targeting the healer with PSW and the same thing happened. Really weird stuff. I'm hoping it's just lag and not another annoying bug.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 29
08-11-2011, 02:20 PM
Yikes. So now it seems like PSW isn't doing jack against the extends at all.

I'm also now hearing that Cryptic stuffed up the Pengs further and made HE trigger the secondary explosion. God knows how much they've broken in a recent patch.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 30
08-11-2011, 03:36 PM
Quote:
Originally Posted by SnogE00F
Yikes. So now it seems like PSW isn't doing jack against the extends at all.

I'm also now hearing that Cryptic stuffed up the Pengs further and made HE trigger the secondary explosion. God knows how much they've broken in a recent patch.
I saw some use PSW3 that knocked ES out but usually I see only PSW1
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 02:53 AM.