Lt. Commander
Join Date: Dec 2007
Posts: 120
# 401
09-15-2011, 01:00 PM
release notes for the patch says that the connie phasers should no longer be uniqe.
well they still are did someone foreget to add the fix to the patch ???
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 402
09-15-2011, 01:24 PM
Nope still not working, still unique, blue and will not let me equip more than 1 of each to any ship!

Come on devs, surely you must of tested this so why are we once again being messed about with??
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 403
09-15-2011, 07:30 PM
Just adding my voice to the fact that these still do not work.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 404
09-15-2011, 08:03 PM
Agreed. Still broken.
Connie phasers still show as blue, and cant equip more than 1.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 405
09-15-2011, 09:39 PM
On the flipside, The Marked Retrofit Phasers are at least not unique so you can equip as many of them as you desire. But on the Connie Phasers, Please fix this. It's sort of annoying reading patch notes of them not having a unique tag when they still do.

Thanks for the Venture and the Vor'Kang on a side note
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 406
09-15-2011, 09:52 PM
Not happy they are not fixed.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 407
09-16-2011, 09:30 AM
Quote:
Originally Posted by DecadeComplete
Not happy they are not fixed.
Completely Agree...

Hey CRYPTIC, Please Fix this "Already Fixed" (NOT SO MUCH) Problem!

And Please, everybody/anybody interested, keep inquiring about this to keep it visible to the Dev's and Mods.

Thank You.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 408
09-16-2011, 10:22 AM
Wait wait wait. Cryptic has said that they "fixed" the Connie phasors already? HAHAHAHAHAHA. Well my dear forum warriors, obviously, we don't "get it" and just can't understand that the Connie phasors in their broken state is actually how it is fixed.

Never mind we were told that Cryptic would actually unbreak the break of the thing that wasn't broken in the first place. I guess this will get fixed when we get content. In other words never.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 409
09-16-2011, 03:16 PM
I don't see what the problem is here. The patch notes CLEARLY STATE that THE PROBLEM HAS BEEN FIXED. So why are we still complaining?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 410
09-16-2011, 03:19 PM
Quote:
Originally Posted by Heezdedjim
I don't see what the problem is here. The patch notes CLEARLY STATE that THE PROBLEM HAS BEEN FIXED. So why are we still complaining?
Because they are still unique. Because we can still only have 1 fore and 1 aft instead of a full set as promised by people like Geko.
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 01:28 AM.