Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 My first real issue ever
09-10-2011, 12:05 PM
Basically the game freezes atter I log in. Twice so far. About a week or so ago it was hard to even log in. Does anyone know of this issue or what?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
09-10-2011, 12:22 PM
Whats your system spec's, also how old is the PC as its a known fact that as PC's get old they start to fail more and more at the silliest of things even things it has done loads of times before with no probs.
But tbh it could be simple thing like overheating or corrupt game files.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
09-10-2011, 01:25 PM
2.70 GHZ

6.00 GB Ram

Champions Online plays perfect. I even logged in with one of my Fed's and it lagged a little but I could play just fine. It seems to only be freezing when I log in with my Klingon.

My drivers are up to date also. So IDK. Maybe just crappy internet connection or lag on the server side of it all.

Oh and my PC is just over a year old
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
09-11-2011, 08:40 AM
There SEEM to be some issues with the servers. I have the same problem if i log in during times of high lag (wich seems to happen in the last days, but thats another thread). It freezes during map - loading?
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 12:16 AM.