Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
Is the 2nd Breen set bonus Superconducting Phase Channels broken? I have equipped the entire set and the energy drain ability is available as is the special engine exhaust trail, but I don't see the SPC icon in my status that used to be there.

My new torpedo build depends on this passive and its boost to torps.

Can anyone offer any information?

Thank you for your time.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
12-23-2011, 03:00 AM
Just logged in to test my torpedo build and it works but has a view odd bugs. The damage boost shows in all areas but the icon only appears above my shield balance symbol; in combat zones. Plus the bonus only works if the set items are equipped before you enter a zone. The bonus stays on if I take the items off as well as not appearing if I add the items after joining a zone. With the torpedo boosting Bridge Officer and the set item torp builds are fun now. Although never found a way to make the Doff boost be useful. I assume it doesn't boost global cool down?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
12-23-2011, 07:20 AM
Is the Bridge officer broke? Not seeing any change in damage.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
12-23-2011, 10:08 AM
Yeah it's broken. The damage boost just doesn't work.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
12-27-2011, 07:30 PM
I'll ping the team so they can look into this. Thanks for reporting it.

Cheers,

Brandon =/\=
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 05:33 PM.