Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Excelsior class for Commanders
01-11-2012, 05:31 AM
Hello there,

I've been playing since beta, lifetime subscriber, and still enjoying the game. I started a new character before Christmas, and have levelled up to commander. I think "Hey I love the Excelsior, and since I've already bought it, I can go use it."

I can't. I appear to have to purchase it again.

I ask simply, wtf? I already purchased it when it first went up on the C-store, it said at the time, for ALL characters (FED). I would like some explanation to this.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-11-2012, 05:42 AM
The C-Store has two Excelsiors, one for Rear Admirals (Excelsior Cruiser Retrofit) the other for Commanders (Advanced Heavy Cruiser) which comes with a transwarp console that boosts a warp core skill and provides a few transwarp options for cruisers..

My guess is you have the Rear Admiral Excelsior.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-11-2012, 06:58 AM
When you originally purchased the T5 Excelsior you didn't also get the T3 version. The T3 version was sold in the Shipyard for EC - that was the only way you could get it. The T5 purchase only entitled you to the T5 ship. With FTP the T3 version has been removed as an EC purchase and changed to a CP purchase - but now comes with a Console as Dane_Strife described above.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
01-11-2012, 07:09 AM
Does the T3 Excelsior come with a skill tree for "smug" and does the transwarp drive occasionally just not work?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
01-11-2012, 07:24 AM
Ah, well that explains it all then, thanks for clearing that up, hadn't been on in a while.

Still, well worth the 800 for that little transwarp console.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
01-11-2012, 09:25 AM
Quote:
Originally Posted by michaelchall
Does the T3 Excelsior come with a skill tree for "smug" and does the transwarp drive occasionally just not work?
I have been a victem of a transwarp 'failure' while in the Sol system... I've only had it once, so it must be a very very rare event, as I've not encountered it since...
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 04:50 AM.