Lt. Commander
Join Date: Dec 2007
Posts: 120
Yesterday I got my hands on the Efficient Impulse Engines; something I had been looking forward to for a while.

Thing is though, I got the Mk VI version, and aside from the bonuses to my power settings, the displayed stats were exactly the same as the Mk IV common engines I was replacing.

This could mean one of 3 things:
  1. There is a display error showing the wrong stats.
  2. The engines themselves are not scaling to level properly.
  3. Efficient Impulse Engines are rubbish.

Anyone know which it is?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-16-2012, 11:30 AM
Might help if you post what they are giving you.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-16-2012, 01:56 PM
Quote:
Originally Posted by Manx View Post
Yesterday I got my hands on the Efficient Impulse Engines; something I had been looking forward to for a while.

Thing is though, I got the Mk VI version, and aside from the bonuses to my power settings, the displayed stats were exactly the same as the Mk IV common engines I was replacing.

This could mean one of 3 things:
  1. There is a display error showing the wrong stats.
  2. The engines themselves are not scaling to level properly.
  3. Efficient Impulse Engines are rubbish.

Anyone know which it is?
Not a shock..
Heck, I have a MK XII Quatum Torpedo that says its a Mk XI in the descrtiption, but has the XII's stats.

I was under the beliefe that all the "efficient" engines had the same stats anyways
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 07:40 PM.