Lt. Commander
Join Date: Dec 2007
Posts: 120
# 11
01-23-2012, 05:59 PM
Quote:
Originally Posted by Tripp_Hazzard
You were able to do bind 1-8 with NUMLOCK off? I should think NUMLOCK would have to be on anyway to prevent the number keys from acting like arrow, Home, End, etc.
That's correct, numlock needs to be on or the numpad special keys act as you mentioned.





Quote:
Originally Posted by xTH3xR34P3Rx
what would you like as a function for the num9 and num0 keys? activation for the tray i presume? if so just tell me and i will tell ya how to bind it via the chatbox.

for example:
/bind Numpad9 "UseTraySlot 0 9" - will activate slot 9 row 1
I just tried to copy and paste this into the chat bar, but unfortunately the numpad 9 key is still not able to be used to input.

I also tried the other method I mentioned earlier, but the numpad 9 key still will not register in the keybind options menu.


I found this as well, no resolution though:


http://forums.startrekonline.com/arc.../t-110242.html
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 12
01-24-2012, 08:58 AM
I think you need to just leave NUMLOCK on all the time. With it off, I think the 9 and 0 are sending signals the binding panel doesn't accept. And you might have to rebind your 1-8 keys with it on, since they may have been sending different "keys" when it was off.

Of course, I may be completely wrong. That is always an option.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 13
01-24-2012, 12:28 PM
Quote:
Originally Posted by Tripp_Hazzard
I think you need to just leave NUMLOCK on all the time. With it off, I think the 9 and 0 are sending signals the binding panel doesn't accept. And you might have to rebind your 1-8 keys with it on, since they may have been sending different "keys" when it was off.

Of course, I may be completely wrong. That is always an option.
I just want to clarify, I leave my NUMLOCK on all of the time.

However, the numbers 9 and 0 specifically do not register within the keybinds options menu, this is with NUMLOCK on.

They function in the chat bar of the game with no issue, but pressing these two keys (and these two keys only) simply does not register in the keybinds menu.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 14
01-25-2012, 06:35 AM
if you remap the 0 and 9 keys to something else, say 'w' and 's', do they work in that case, or is it that STO does not accept input from those two physical keys?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 15
01-26-2012, 02:56 PM
Quote:
Originally Posted by USS_Ultimatum
I just want to clarify, I leave my NUMLOCK on all of the time.

However, the numbers 9 and 0 specifically do not register within the keybinds options menu, this is with NUMLOCK on.

They function in the chat bar of the game with no issue, but pressing these two keys (and these two keys only) simply does not register in the keybinds menu.
I got it to work right now by doing the following:

Go to Options -> Key Binds
Down to Skill #9, #10
DISABLE NUMLOCK!
Now you can remap skill 9 and 10 to the numpad keys 9 and 0.
Re-enable numlock.
Do the same for Ctrl and Alt.

And final step, make sure you have re-enabled numlock and rejoice

EDIT: You don't even have to re-enable it.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 16
01-26-2012, 03:47 PM
Quote:
Originally Posted by BDS
if you remap the 0 and 9 keys to something else, say 'w' and 's', do they work in that case, or is it that STO does not accept input from those two physical keys?
STO is not accepting input from the physical keys with NUMLOCK on.

I've tried mapping them to other keystrokes, with no luck.

Quote:
Originally Posted by LordPlatin View Post
I got it to work right now by doing the following:

Go to Options -> Key Binds
Down to Skill #9, #10
DISABLE NUMLOCK!
Now you can remap skill 9 and 10 to the numpad keys 9 and 0.
Re-enable numlock.
Do the same for Ctrl and Alt.

And final step, make sure you have re-enabled numlock and rejoice

EDIT: You don't even have to re-enable it.
I tried this just now, but unfortunately the key does not respond when pressed.

I was able to map the keys with NUMLOCK off, but once NUMLOCK was turned back on, pressing them did nothing.


Thanks for trying to help though.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 17
01-28-2012, 11:03 AM
Quote:
Originally Posted by USS_Ultimatum
STO is not accepting input from the physical keys with NUMLOCK on.

I've tried mapping them to other keystrokes, with no luck.



I tried this just now, but unfortunately the key does not respond when pressed.

I was able to map the keys with NUMLOCK off, but once NUMLOCK was turned back on, pressing them did nothing.


Thanks for trying to help though.
Huh, strange, worked for me. Tried remapping Ctrl to Shift, that failed completely the way you described it. Fun fact: After I did remap the 9 and 0 keys, the system forgot my 1 key, had to remap that, too.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 18
01-31-2012, 09:00 PM
Quote:
Originally Posted by LordPlatin View Post
Huh, strange, worked for me. Tried remapping Ctrl to Shift, that failed completely the way you described it. Fun fact: After I did remap the 9 and 0 keys, the system forgot my 1 key, had to remap that, too.
I'm stumped at this point for options on how to resolve this.

I'm not even sure where to begin looking for more ideas.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 19
02-03-2012, 05:00 PM
Ok a little something new.


I created a bind file and then added:

Numpad9 "UseTraySlot0 8"

I hadn't noticed when I previously attempted this, but when I press this key this is the message I get:


[System] "TrayExecByTrayNotifyAudio" takes 5 argument(s).
[System] trayexecbytraynotifyaudio <int> <int> <int> <string> <string>


Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 03:28 AM.