Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Can't Log in to STO Launcher
01-22-2012, 10:01 AM
I seem to be having a lot of trouble logging into the STO launcher. It doesn't allow me to log in with my Cryptic credentials. The Perfect World radio button is all ways highlighted. I dont think me account was linked correctly.
I cant submit a support ticket because i dont have a prefect world account.

I am a lifetime STO player, and I cant even play the game. Please can someone tell me how to remedy this issue?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
01-22-2012, 10:01 AM
Quote:
Originally Posted by species_420 View Post
I seem to be having a lot of trouble logging into the STO launcher. It doesn't allow me to log in with my Cryptic credentials. The Perfect World radio button is all ways highlighted. I dont think me account was linked correctly.
I cant submit a support ticket because i dont have a prefect world account.

I am a lifetime STO player, and I cant even play the game. Please can someone tell me how to remedy this issue?
Servers are down for "restart."

Been down for going on 2 hours now with no update.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
01-22-2012, 11:14 AM
Quote:
Originally Posted by species_420 View Post
I seem to be having a lot of trouble logging into the STO launcher. It doesn't allow me to log in with my Cryptic credentials. The Perfect World radio button is all ways highlighted. I dont think me account was linked correctly.
I cant submit a support ticket because i dont have a prefect world account.

I am a lifetime STO player, and I cant even play the game. Please can someone tell me how to remedy this issue?
It could be related to your MSIE settings (as the launcher makes use of some of those). A Dev posted asome way to check oand configure things in that regard for players who's ability to chose credential type isn't working. (link to post.)
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
01-22-2012, 11:59 AM
Quote:
Originally Posted by species_420 View Post
I seem to be having a lot of trouble logging into the STO launcher. It doesn't allow me to log in with my Cryptic credentials. The Perfect World radio button is all ways highlighted. I dont think me account was linked correctly.
I cant submit a support ticket because i dont have a prefect world account.

I am a lifetime STO player, and I cant even play the game. Please can someone tell me how to remedy this issue?
You can still access the STO support page www.startrekonline.com/support. The PWE support page contains a link at the top of the page for Cryptic users, right under the search box.

The direct link to the Cryptic Support page is here: http://support.crypticstudios.com/startrekonline

However, at some point in the future, it may become necessary to create a PWE account, as the two support systems are in the process of being merged into a single support system.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 03:43 PM.