Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Gear Not Equiping
02-07-2012, 10:48 PM
So I couldn't find it anywhere else.

I recently purchased two pieces of armor
Physical Augmentation Armor Mk X [Ap] [Pha] [PolAp]
Physical Augmentation Armor Mk X [HP] [HPP]
for my level 44 kling.

However, the armor refuses to equip stating "You do not meet the Requirements for this Item"

Has anyone else experienced this or know what is going on here?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-07-2012, 10:53 PM
I've had this once before on a Federation admiral.

I did find that as soon as i hit level 45 i could equip. I think its a slight bug in the system left over from the old leveling system.

once you hit 45 you should be fine to equip it.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-07-2012, 11:49 PM
I assume you've tried re-logging, or tried equipping it while in space, or changing instances, try all those things. If its still not working, try spending any skill points you have. Good luck
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
02-08-2012, 12:01 AM
Quote:
Originally Posted by KayninRedmoon
However, the armor refuses to equip stating "You do not meet the Requirements for this Item"

Has anyone else experienced this or know what is going on here?
Now I've encountered equipment where the Common and Uncommon version could be equipped by a Rear Admiral Lower, the Rare version could only be equipped by a Real Admiral Upper.... Since you're only level 44, you may have run into the same situation... Read the item description carefully to see who is intended to use it...
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5 Got it
02-08-2012, 09:17 AM
Yeah the moment I hit lvl 45 I was Fine thanks for the heads up, Just took me grinding the PvP and DoFFs a bit.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
02-08-2012, 09:19 AM
Quote:
Originally Posted by The-Doctor.
I assume you've tried re-logging, or tried equipping it while in space, or changing instances, try all those things. If its still not working, try spending any skill points you have. Good luck
Yeah Don't Worry I know the basics. Alot of my friends work Tech Support and would have smacked me if I hadn't done that. BTW love the name and Image, Would it be safe to assume your ship is named the USS/IKS T.A.R.D.I.S.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 03:31 AM.