Lt. Commander
Join Date: Dec 2007
Posts: 120
So I bite the bullet and I went gold.

That was 2 days ago. Since then I have constant disconnects and lag. Big lag.
I've been playing as silver member for like 3 weeks, and besides occasional lag spike, I never had issues of such amplitude.

In like 4 hours of gameplay I am disconnected from server about 10-12 times, and lag spikes are more than 2 seconds long now.

Before subscribing to STO, the only thing I knew about Star Trek universe was that the main character Picard is bald and they have gay costumes. I don't know much more now, and I'm honestly not interested to find out.

The only thing I do, and the only thing I'm in STO for, is PvP. Is easy to understand why the lag is causing me such amount of distress. And to lose a match in Arena because I get d/c, is even more annoying.

I did the nettest thingie with the .exe from the site, even I know is useless. Why? Because 3 days ago, when I was playing without paying you, guys, I had no disconnects nor lag. So don't come to me with advices about my comp, my net pipe or about settings. 3 days ago was fine. Nothing changed besides my credit card amount and your bank account..

I don't know how the things are managed on your servers, but I assume gold players have a separate one. Wich I assume is at least 2 years old. F2P players prolly have a disctinct machine purchased recently to accomodate the influx.

Bleah, I digress. Fix the lag problem and the disconnects, or this is going to be the first and last month I pay for your services.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-20-2012, 10:33 AM
yeah sadly for me its the same too the game was perfectly smooth before 2 days yet it is stop and go
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-20-2012, 10:48 AM
Had same problem..then I took my PC off wireless..and wow...no more lag. Just saying.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 02:56 PM.