Lt. Commander
Join Date: Dec 2007
Posts: 120
I can't seem to get invisible walls working properly when putting them in, say, a small pond anymore. It's suddenly as if they don't exist at all, as opposed to about a week ago when they were working fine. Now, I seem to have to put all walls in water as "tall", and set them at -20Y based on terrain before they even work as they should.

Is this a "thing" now? Did I miss something? Or was I doing something wrong to begin with and hadn't noticed?
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
02-25-2012, 09:12 PM
Is it the walls or somthing your trying to trap that is the issue. Every NPC or Boff has a radius in which they are unable to occupy the same space as an object. If this is the case try using a trigger to put the npc in place after the invisible walls have been generated.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 3
02-28-2012, 09:13 AM
Quote:
Originally Posted by filbones View Post
Is it the walls or somthing your trying to trap that is the issue. Every NPC or Boff has a radius in which they are unable to occupy the same space as an object. If this is the case try using a trigger to put the npc in place after the invisible walls have been generated.
Nope, it's the walls themselves. Before I use the walls to trap anything, I always go to the map preview and make sure that the walls are actually there by, you know, running face-first into them. The walls I put down on dry land right next to the water? Work fine. Put invisible walls IN the water? Even if it's ankle-high? Nope. Can run around without obstruction.

I DID try putting down NPC enemies to test afterwards, to see if the walls were even working as a way to not let them "see" you, and they didn't work in that capacity either.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 4
02-28-2012, 11:14 AM
In my lastest mission, I did everything I could to make invis walls disappear using triggers. They don't seem to be working.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 5
02-28-2012, 09:18 PM
Quote:
Originally Posted by Kirkfat View Post
In my lastest mission, I did everything I could to make invis walls disappear using triggers. They don't seem to be working.
If they're invisible, are you sure you're clicking on the actual invisible walls, not empty space?



Sorry - couldn't resist. Please return to cranking out fabulous new Foundry content, Kirkfat.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 6
03-15-2012, 10:16 PM
Going to have to reply to myself on this one, because I've run into an absolutely INFURIATING bug now related to my original post.

Because now the invisible walls will work in the water I put them in...on the PREVIEW maps only. After publishing? People are telling me there's no wall there. Went to inspect myself using my main character, and yup, in the spots where the walls were working perfectly well in the preview maps, they were completely absent from the final product. Big 'ol 5k tall walls, placed -30 into the ground for good measure. Not there, but only if the walls are placed in water, looks like.

And here I was about to say "my first test maps work fine, on to do something serious". Now I kind of don't want to do anything else with the Foundry, if there's such bugs that mean no matter how much you test them in the previews, they could possibly not work at all as intended in the actual published version.


EDIT: You know, I should have probably put my published mission title in here after I actually published it, so that people could see what I'm talking about.

My test mission is called "A Room Filled With Crazy", by milesredria.

The problem shows up especially on my third map in the mission. You go up to a pond, interact with an object, a dialog fires off, and if you get a negative response to the dialog, you'd get jumped.
The way I have it set up is the invisible wall cage (made of 4 walls, and yes, there's no gaps) are to show IMMEDIATELY when that map starts, and the NPCs are added/warp in when you interact with a trigger nearby. "Fail" the dialog, and the cage drops.
And it does still work in the preview tool....but when you go and try it with the published version, nope. Walls in the water are gone completely. So the enemies warp in, and you just plain get jumped in the middle of the dialog instead.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 12:32 PM.