Career Officer
Join Date: Jun 2012
Posts: 157
# 1 Game wount start
03-15-2013, 11:47 AM
I just finished installing the new patch and when I try to play the game my screen will flicker on and off a few times during the Cryptic loading screen and then when the loading bar gets to around 75% my PC will crash. I tried it twice so far and both times the same thing happened. I disabled auto patcher and the game is set to launch fullscreen, im about to try launching it windowed so ill post the results after.

Also im running Windows 8 so not sure if thats the problem since I never had any issues on 7.

Edit: ok so the game runs fine in windowed mode, when the game loaded and I chose my char everything was fine. I went into the option to go fullscreen, and instantly the flickering started again. The screen flashed black twice before I alt-tabbed and closed the game. When I got back to my desktop their was an error message saying the Nvidia drivers crashed. So can I do anything to fix this or is this a problem with the game?

Last edited by gilion; 03-15-2013 at 11:58 AM.
Career Officer
Join Date: Feb 2013
Posts: 486
# 2
03-15-2013, 01:49 PM
Since your running WinH8, I presume your Nvidia drivers are at least recent, if not up-to-date. But you should check for updated drivers.

You say it worked fine on Win7 - was that on the same hardware (the same PC)? If so I'd say this is a WinH8 issue. IOW a Microsoft problem, not an Nvidia or Cryptic problem.
Career Officer
Join Date: Jun 2012
Posts: 157
# 3
03-15-2013, 04:30 PM
No actually my laptop is running Windows 8 and my desktop is running 7. I just thought I would mention it since I never got any problems with the game until I tried it on Windows 8.

And yes my drivers are up to date.

Another update, the game also works fine in windowed maximized view, which looks exactly like fullscreen so I really dont know what the problem is. Fullscreen worked fine last week, and I dont think I did anything that could have affected the game.
Career Officer
Join Date: Feb 2013
Posts: 486
# 4
03-15-2013, 04:44 PM
Um, unless you bought a high-end gaming laptop, you should not expect any decent graphics performance from most laptops. Kudos if it has a discrete GPU, otherwise you're running on craptastic integrated graphics.
Career Officer
Join Date: Jun 2012
Posts: 157
# 5
03-16-2013, 10:45 AM
I have a Lenovo Y500 that is running 2 NVIDIA 650M SLI, I can run the game on max graphics no problem. The only problem I get is when I try to make the game fullscreen, my screen will flicker on and off everyone 2 sec and then the game will crash after the screen turns off about 4 times. When I play the game in Windowed Maximized view (which like I said looks exactly like fullscreen and I dont know the difference) the game works fine, the moment I set it to fullscreen is when I start getting problems.
Career Officer
Join Date: Feb 2013
Posts: 486
# 6
03-16-2013, 03:03 PM
Cool that should be pretty good for gaming then. As for your fullscreen issue, since it works for you on Win7, as it does for me, I still say it smells like a WinH8 issue.

I think I'll be sticking with Win7 for a long time - I see no upside to running WinH8's Metro interface on a desktop.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 08:32 AM.