Lt. Commander
Join Date: Jun 2012
Posts: 136
# 251
12-15-2012, 02:08 PM
Ta, Brandon. I did, and received the usual receive confirmation.

I just wanted to know if there was anyone else having this issue, or if I was just a **** who had forgotten to add/remove a check somewhere in my settings.
Survivor of Romulus
Join Date: Jun 2012
Posts: 801
# 252
12-15-2012, 02:21 PM
This is a VERY long outstanding problem that has been reported many times, but that they have never confirmed that they have received anything about it let alone that there are going to ever fix it.
Captain
Join Date: Jul 2012
Posts: 1,273
# 253
12-15-2012, 02:38 PM
Quote:
Originally Posted by voicesdark View Post
This is a VERY long outstanding problem that has been reported many times, but that they have never confirmed that they have received anything about it let alone that there are going to ever fix it.
Yeah, this has been a problem ever since we switched over to these new forums back in June.
Career Officer
Join Date: Jun 2012
Posts: 1,325
# 254
12-15-2012, 03:10 PM
I still have an outstanding payment problem, the site wont accept my card, when I tried getting a site support ticket it just refused to load for me. This was several weeks ago.

Kinda sad really, it's almost as if they don't want my money despite my rampant attempts to get help!
Lt. Commander
Join Date: Jun 2012
Posts: 136
# 255
12-15-2012, 03:10 PM
Very weird, since I actually have been able to use the support page between June and a few days ago. Just all of a sudden... poof... kaput.
Ensign
Join Date: Dec 2012
Posts: 1
# 256
12-16-2012, 07:26 PM
Hello Captain!

At this time, you may only post replies to threads that have already been created. After a certain amount of time has passed since your registration date, you will be able to create new threads in forums that allow it.

Thanks,

The Star Trek Online Community Team

LOL so much for paying.
Lt. Commander
Join Date: Jun 2012
Posts: 136
# 257
12-19-2012, 02:29 AM
So, after mailing support that I cannot load the support page due to the redirect loop. they respond that I should submit a bug report.
Quote:
This may be done by selecting 'Bug Report' from the list of available help options
Can someone here verify that e-mails are actually read before being brushed off with a default reply?
Career Officer
Join Date: Oct 2012
Posts: 294
# 258
12-19-2012, 04:52 AM
lmao. good job cryptic. quality support as always.
Starfleet Veteran
Join Date: Jun 2012
Posts: 232
hi Sir,

Can I please Have the @mail of Customer Service of STO ?

Thx in advance for your answers !


Allfather
Lord of Destruction - Allfather - Holy Lamb of Knowledge - Commander of the 7 Nation Army - The Victory Sire
Lt. Commander
Join Date: Jun 2012
Posts: 136
# 260
12-23-2012, 03:46 PM
If you have an issue for which you need customer support, you should submit a ticket via the support website at https://support.perfectworld.com or send an email to customerservice@perfectworld.com.
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 05:45 PM.