Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lieutenant
Join Date: Jul 2012
Posts: 35
# 11
07-18-2012, 03:49 AM
This just started on my toons when season 6 came out. The exchange does not allow me to post anything. The system says "Item has been successfully posted" however it does not show up on the search. After 4 tickets I am starting to wonder if this will ever be fixed?!
(-_-)
Captain
Join Date: Jun 2012
Posts: 2,007
# 12
07-18-2012, 05:32 AM
This is the same bug that's been around for months. It's just gotten worse. You have to select the rarity and the department to see the updated listing for an item.

There should be a couple dozen threads explaining this if you search for exchange.
---
Took 20 minutes to get that screencap and her arm is still doing through the armrest
Dr. Mike's Steak Dinner

35 Starbase Projects done. 715 Projects remaining
Starfleet Veteran
Join Date: Jun 2012
Posts: 609
# 13
07-18-2012, 11:19 AM
I dont' care how many threads there are on this topic. The exchange is a REQUIRED GAME MECHANIC. The fact that it has yet to be fixed is astonishing.

ALOT of items before season 6 never even showed up in search, even if you did quality. The exchange doesn't work right, it needs an OVERHAUL. Fix it.

| Join Date: January 2009 | Computer | Fleet: Broken Wings |
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 02:16 AM.