Go Back   Star Trek Online > Support > Gameplay Bug Reports
Login

Notices

Reply
 
Thread Tools Display Modes
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 Another Odyssey Aquarius Bug
05-23-2012, 05:33 AM
Another bug with the Aquarius, this time during a Red Alert.

I engaged the Borg mothership in Alpha Trianguli around 5:00 AM Pacific. During the fight I was about to recall the Aquarius, but the cooldown timer had '3 minutes' on it - which made no sense as it was still out, and still fighting. Furthermore the saucer sep button was greyed out.

I'm now in the middle of sector space with a '5 minute' on the button as though I was still waiting for a cooldown - which I'm pretty sure I'm not supposed to have, since I have the whole Ody set and I've never seen a cooldown longer than 4 minutes for any of its features. The only thing directly related that I can think of is that I deployed Work Bees to another player at around 12 KM or so just before I entered the fight myself.

This is a tactical character with a tactical Odyssey, and the aforementioned full Ody set.

I would be curious to see if there is anyone else with a similar experience - I'm considering pulling the Aquarius off of my tray as the saucer sep is MUCH more important to me.
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2 Oddyssey Bugs
05-27-2012, 05:34 PM
So Cryptic, wenn are you going to correct ALL the bugs on the oddy??????
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 11:01 AM.