Lt. Commander
Join Date: Dec 2007
Posts: 120
# 1 9800M GTX SLI Frame Rate
05-23-2012, 08:31 PM
Hello everyone.
I'm running a fairly out of date system to todays standards and I'm just wondering if theres anything I can do to improve my framerate.

Below is a copy of my DXdiag file, just to give an idea of system specs, I had to snip it some to stay under the post charater limit . Now typically in game I'm getting between 15-25 fps in most situations running the newest Nvidia driver. This seems low to me, but perhaps thats just wishful thinking. Most other games I play I get 50 fps or so in the average situation, and in most DX10 games I can get over 100 fps, yet STO just seems to be a slideshow. Is there anything I can do to improve this? Any help would be greatly appreciated



Quote:
------------------
System Information
------------------
Time of this report: 5/23/2012, 21:23:46
Machine name: THOR-PC
Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120330-1504)
Language: English (Regional Setting: English)
System Manufacturer: Dell Inc.
System Model: MXG071
BIOS: Phoenix ROM BIOS PLUS Version 1.10 A11
Processor: Intel(R) Core(TM)2 Extreme CPU X9000 @ 2.80GHz (2 CPUs), ~3.4GHz
Memory: 4096MB RAM
Available OS Memory: 4094MB RAM
Page File: 3848MB used, 4338MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 64bit Unicode
Lt. Commander
Join Date: Dec 2007
Posts: 120
# 2
05-24-2012, 07:56 AM
Same issue with my system, two HD 6750 and it works like sh*t.

Even 1 card gives me just abysmal frame rates. SLI and Crossfire are really not supported in this game. Forget it.

Time for a new card buddy I will definately do that. No more crossfire or SLI ever, ever again for me.
Starfleet Veteran
Join Date: Jun 2012
Posts: 92
# 3
07-01-2012, 04:27 PM
Quote:
Originally Posted by Archived Post View Post
Hello everyone.
I'm running a fairly out of date system to todays standards and I'm just wondering if theres anything I can do to improve my framerate.

Below is a copy of my DXdiag file, just to give an idea of system specs, I had to snip it some to stay under the post charater limit . Now typically in game I'm getting between 15-25 fps in most situations running the newest Nvidia driver. This seems low to me, but perhaps thats just wishful thinking. Most other games I play I get 50 fps or so in the average situation, and in most DX10 games I can get over 100 fps, yet STO just seems to be a slideshow. Is there anything I can do to improve this? Any help would be greatly appreciated
I think my set up is not as good as yours, but I found a way to increase my frame rates. I went to the troubleshooting section in the video tab under options. The troubleshooting options allow you to change which direct x your using. I always assumed I was using directx 11, but was using 9 before I found these settings. Also you can choose the amount of video memory limit. Mine is 1024mb, so I chose the 1024mb + option, and that made a world of difference. I play STO in 3d mode in 1080p. I also have a lot of my settings maxed out. Before, I would have to focus on performance than quality, now I can focus on high quality without any cost to performance
Lieutenant
Join Date: Jun 2012
Posts: 35
# 4
07-01-2012, 11:40 PM
Guys,STO does not support SLI and Crossfire
Captain
Join Date: Jun 2012
Posts: 1,069
# 5
07-02-2012, 12:05 AM
Quote:
Originally Posted by Archived Post View Post
Time for a new card buddy

Why?I don't remember any change to graphics engine and that graphics card is from the same generation with this game.If its not working (and it should since mmos are meant to be playable on many normal not high end pcs) it means the devs have to fix the problems somehow.
Career Officer
Join Date: Jun 2012
Posts: 514
# 6
07-07-2012, 08:07 PM
Its funny, but you guys are all wrong.

This game's FPS is borked on the fastest GPU's, even in SLI or Crossfire, simply because the game's UI/HUD is drawn by the CPU. The HUD/UI interface is not really GPU accelerated like most modern games.

Thus this means that no matter what videocard you put in, or how low you put your graphics settings, in particular scenarios the FPS just drops considerably.

The game seems to be using 1 thread for the normal stuff, and 1 for the UI draw part.

The only solution for high FPS is to take a very good CPU with a very fast performance per core, since having a 4Ghz dual or 4GHz quad (From the same CPU architecture will make at most 5% difference. Simpy because the game doesnt utilize more then 2 threads.


I ran my Q9450 Quad at 3.8GHz and its still bottlenecking the game and dropping my FPS to below 35-40fps at some points. Both threads are about maxed out and leaving my pretty GTX670 with nothing to do. Running everything on max, with 8x >Super<sampling

Lowering my GPU settings have about no effect, the only thing that affects the FPS in those situations somewhat is lowering the resolution. Thats a side effect of the CPU having less to redraw because the resolution simply decreased.

Its just simply like this; The higher your screen resolution, the more the CPU has to handle in terms of redrawing the HUD/UI parts, the more the CPU will become a bottleneck. The FPS simply hangs on the speed of your CPU in cases where upgrading your GPU card or lowering your GPU settings do not have any significant effect in some areas of the game.


Until Cryptic finally optimizes their UI/HUD interface and properly accelerating it by the GPU, this problem will persist for alot of people.

---------

Secondly, that the Game doesnt support SLI or Crossfire doesn't mean it will not work properly. Using AFR (Alternate frame rendering), with a fast enough CPU your cards will utilize the game rendering very nicely. The only bug here is that shadows needs to be disabled on ground otherwise you will encounter flickering. Even Optimize 1x1 (For ATI) seems to work pretty ok, without shadow flickering problems.

Last edited by marctraiderz; 07-07-2012 at 08:13 PM.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -7. The time now is 02:42 AM.